add plugin(3g-modem-manager)
authorkos <kos@dev3>
Mon, 16 Apr 2012 12:40:40 +0000 (21:40 +0900)
committerkos <kos@dev3>
Mon, 16 Apr 2012 12:40:40 +0000 (21:40 +0900)
13 files changed:
conf/machine/bm750.conf
conf/machine/include/vuplus-modules.inc
conf/machine/vusolo.conf
conf/machine/vuultimo.conf
conf/machine/vuuno.conf
recipes/enigma2/enigma2.bb
recipes/tasks/task-boot.bb
recipes/tasks/task-vuplus-enigma2.bb
recipes/usbutils/files/usb-modeswitch-data_20120215.patch [new file with mode: 0644]
recipes/usbutils/usbmodeswitch-data_20120120.bb [new file with mode: 0644]
recipes/usbutils/usbmodeswitch_1.2.3.bb [new file with mode: 0644]
recipes/wvdial/files/wvdial-vuplus_001.patch [new file with mode: 0644]
recipes/wvdial/wvdial_1.60.bb

index 9c71749..a034479 100644 (file)
@@ -50,6 +50,7 @@ require conf/machine/include/vuplus-modules.inc
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-bm750', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-bm750', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-bm750', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-bm750', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-bm750', '3.1.1', '${KERNEL_3G_MODULES}', '', d)}
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-bm750', '2.6.18', '0.5.10', '0.7.3', d)}
 
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-bm750', '2.6.18', '0.5.10', '0.7.3', d)}
 
index 0902488..f6d0008 100644 (file)
@@ -2,6 +2,14 @@
 # Kernel Modules
 #
 
 # Kernel Modules
 #
 
+KERNEL_3G_MODULES = " \
+        kernel-module-ppp-async \
+        kernel-module-ppp-deflate \
+        kernel-module-ppp-synctty \
+        kernel-module-ppp-generic \
+        kernel-module-slhc \
+        kernel-module-usbserial \
+        "
 
 KERNEL_WIFI_MODULES = " \
        kernel-module-ath9k-htc \
 
 KERNEL_WIFI_MODULES = " \
        kernel-module-ath9k-htc \
index 4eb9ea9..14ec952 100644 (file)
@@ -50,6 +50,7 @@ require conf/machine/include/vuplus-modules.inc
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vusolo', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vusolo', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vusolo', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vusolo', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vusolo', '3.1.1', '${KERNEL_3G_MODULES}', '', d)}
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-vusolo', '2.6.18', '0.5.10', '0.7.3', d)}
 
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-vusolo', '2.6.18', '0.5.10', '0.7.3', d)}
 
index e978d10..9f9e606 100644 (file)
@@ -48,6 +48,7 @@ require conf/machine/include/vuplus-modules.inc
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '3.1.1', '${KERNEL_3G_MODULES}', '', d)}
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '2.6.18', '0.5.10', '0.7.3', d)}
 
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '2.6.18', '0.5.10', '0.7.3', d)}
 
index 6ba6d91..c922a24 100644 (file)
@@ -49,6 +49,7 @@ require conf/machine/include/vuplus-modules.inc
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuuno', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuuno', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuuno', '3.1.1', '${KERNEL_WIFI_MODULES}', '', d)}
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuuno', '3.1.1', '${KERNEL_DVB_MODULES}', '', d)}
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS += ${@base_contains('PREFERRED_VERSION_linux-vuuno', '3.1.1', '${KERNEL_3G_MODULES}', '', d)}
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-vuuno', '2.6.18', '0.5.10', '0.7.3', d)}
 
 
 PREFERRED_VERSION_wpa-supplicant = ${@base_contains('PREFERRED_VERSION_linux-vuuno', '2.6.18', '0.5.10', '0.7.3', d)}
 
index 8e1d77f..b6f5ac3 100644 (file)
@@ -3,7 +3,7 @@ MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        dreambox-dvbincludes freetype libdvbsi++ python swig-native \
        libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        dreambox-dvbincludes freetype libdvbsi++ python swig-native \
        libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
-       gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi"
+       gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data "
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
        python-pickle gst-plugin-app gst-plugin-fragmented \
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
        python-pickle gst-plugin-app gst-plugin-fragmented \
@@ -65,9 +65,10 @@ DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy s
 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
 DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
 DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
+RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usbmodeswitch usbmodeswitch-data wvdial wvstreams libwvutils4.6 libwvstreams-extras libuniconf4.6"
 
 PN = "enigma2"
 
 PN = "enigma2"
-PR = "r26"
+PR = "r27"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
index 7b756d5..45871fc 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Basic task to get a device booting"
 DESCRIPTION = "Basic task to get a device booting"
-PR = "r66"
+PR = "r67"
 
 inherit task
 
 
 inherit task
 
index d0bfb60..ac48fb8 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Vuplus: E2 Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
 DESCRIPTION = "Vuplus: E2 Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
-PR = "r15"
+PR = "r16"
 
 inherit task
 
 
 inherit task
 
@@ -31,6 +31,7 @@ RDEPENDS_task-vuplus-enigma2 = "\
   enigma2-plugins-meta \
   enigma2-skins-meta \   
   enigma2-plugin-systemplugins-crashreport \
   enigma2-plugins-meta \
   enigma2-skins-meta \   
   enigma2-plugin-systemplugins-crashreport \
+  enigma2-plugin-systemplugins-3gmodemmanager \
 "
 
 RRECOMMENDS_task-vuplus-enigma2 = "\
 "
 
 RRECOMMENDS_task-vuplus-enigma2 = "\
diff --git a/recipes/usbutils/files/usb-modeswitch-data_20120215.patch b/recipes/usbutils/files/usb-modeswitch-data_20120215.patch
new file mode 100644 (file)
index 0000000..72aa4e1
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/usb_modeswitch.d/16d8:700b b/usb_modeswitch.d/16d8:700b
+index 6e8179f..826a2cb 100644
+--- a/usb_modeswitch.d/16d8:700b
++++ b/usb_modeswitch.d/16d8:700b
+@@ -1,6 +1,9 @@
+ # C-motech CHU-629S (Variant)
+-TargetClass=0xff
++DefaultVendor= 0x16d8
++DefaultProduct=0x700b
++TargetClass=0xff
++CheckSuccess=20
+ MessageContent="55534243123456782400000080000dfe524445564348473d4e444953000000"
diff --git a/recipes/usbutils/usbmodeswitch-data_20120120.bb b/recipes/usbutils/usbmodeswitch-data_20120120.bb
new file mode 100644 (file)
index 0000000..572e891
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "tool to switch multidevice usb modes"
+LICENSE = "GPL"
+
+PV="20120120"
+SRC_URI=" \
+       http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-data-${PV}.tar.bz2 \
+       file://usb-modeswitch-data_20120215.patch;patch=1\
+       "
+
+S = "${WORKDIR}/usb-modeswitch-data-${PV}"
+
+do_compile() {
+}
+
+do_install() {
+       #install -d ${D}/usr/share/usb_modeswitch
+       #install -d ${D}/etc/usb_modeswitch.d
+       #install -d ${D}/lib/udev/rules.d
+       #install -m 0755 ${S}/40-usb_modeswitch.rules ${D}/lib/udev/rules.d/
+       #install -m 0755 ${S}/usb_modeswitch.d/* ${D}/usr/share/usb_modeswitch/
+       DESTDIR=${D} make install
+}
+
+PACKAGES =+ "usbmodeswitch-data"
+FILES_${PN} += "/etc /lib /usr"
+#FILES_${PN} += "/lib"
+#FILES_${PN} += "/usr"
diff --git a/recipes/usbutils/usbmodeswitch_1.2.3.bb b/recipes/usbutils/usbmodeswitch_1.2.3.bb
new file mode 100644 (file)
index 0000000..9272366
--- /dev/null
@@ -0,0 +1,15 @@
+DESCRIPTION = "tool to switch multidevice usb modes"
+LICENSE = "GPL"
+
+DEPENDS = "libusb"
+
+PV=1.2.3
+SRC_URI = "http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-${PV}.tar.bz2"
+
+S = "${WORKDIR}/usb-modeswitch-${PV}"
+
+do_install() {
+        install -d ${D}${bindir}
+        install -m 0755 ${S}/usb_modeswitch ${D}${bindir}
+}
+
diff --git a/recipes/wvdial/files/wvdial-vuplus_001.patch b/recipes/wvdial/files/wvdial-vuplus_001.patch
new file mode 100644 (file)
index 0000000..f897a5c
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/wvmodemscan.cc b/wvmodemscan.cc
+index bf59924..ef5ab87 100644
+--- a/wvmodemscan.cc
++++ b/wvmodemscan.cc
+@@ -485,6 +485,7 @@ const char *WvModemScan::is_isdn() const
+ static int fileselect(const struct dirent *e)
+ {
++#if 0
+     return !strncmp(e->d_name, "ttyS", 4)             // serial
+        || !strncmp(e->d_name, "ttyLT", 5)     // Lucent WinModem
+        || !strncmp(e->d_name, "ttyACM", 6)      // USB acm Modems
+@@ -493,6 +494,13 @@ static int fileselect(const struct dirent *e)
+        || !strncmp(e->d_name, "ttySL", 5);    // SmartLink WinModem
+       // (no internal ISDN support)   || !strncmp(e->d_name, "ttyI", 4);
++#else
++    return !strncmp(e->d_name, "ttyLT", 5)      // Lucent WinModem
++       || !strncmp(e->d_name, "ttyACM", 6)      // USB acm Modems
++       || !strncmp(e->d_name, "ttyUSB", 6)      // Modems on USB RS232
++       || !strncmp(e->d_name, "ircomm", 6)      // Handys over IrDA
++       || !strncmp(e->d_name, "ttySL", 5);      // SmartLink WinModem
++#endif
+ }
index 03de436..f076199 100644 (file)
@@ -1,10 +1,13 @@
 HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
 DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
 
 HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
 DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
 
-PR = "r2"
+PR = "r3"
 
 LICENSE = "LGPL"
 
 LICENSE = "LGPL"
-SRC_URI = "http://www.alumnit.ca/download/wvdial-1.60.tar.gz"
+SRC_URI = "\
+       http://www.alumnit.ca/download/wvdial-1.60.tar.gz \
+       file://wvdial-vuplus_001.patch;patch=1 \
+       "
 
 DEPENDS = "wvstreams"
 RDEPENDS = "ppp"
 
 DEPENDS = "wvstreams"
 RDEPENDS = "ppp"