add plugin(3g-modem-manager)
[vuplus_openembedded] / recipes / tasks / task-boot.bb
1 DESCRIPTION = "Basic task to get a device booting"
2 PR = "r67"
3
4 inherit task
5
6 # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
7 #
8 PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10 #
11 # those ones can be set in machine config to supply packages needed to get machine booting
12 #
13 MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
14 MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
15
16 # update-alternatives script installed in rootfs needs to be the same as
17 # u-a script used for building image which is defined with
18 # PREFERRED_PROVIDER_virtual/update-alternatives-native
19
20 DISTRO_UPDATE_ALTERNATIVES ?= "${PREFERRED_PROVIDER_virtual/update-alternatives}"
21
22 # Make sure we build the kernel
23 DEPENDS = "virtual/kernel"
24
25 #
26 # minimal set of packages - needed to boot
27 #
28 RDEPENDS_task-boot = "\
29     base-files \
30     base-passwd \
31     busybox \
32     ${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \
33     modutils-initscripts \
34     netbase \
35     ${DISTRO_UPDATE_ALTERNATIVES} \
36     ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
37     "
38
39 RRECOMMENDS_task-boot = "\
40     kernel \
41     ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
42     "