Merge commit 'dm/opendreambox-1.6' into test_1130
authorschon <schon@dev03-server>
Tue, 30 Nov 2010 05:11:10 +0000 (14:11 +0900)
committerschon <schon@dev03-server>
Tue, 30 Nov 2010 05:11:10 +0000 (14:11 +0900)
Conflicts:
recipes/aio-grab/aio-grab.bb
recipes/autofs/autofs_4.1.4.bb
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2.bb
recipes/opkg/opkg-nogpg_svn.bb
recipes/tuxbox/tuxbox-tuxtxt-32bpp.bb

13 files changed:
1  2 
recipes/aio-grab/aio-grab.bb
recipes/autofs/autofs_4.1.4.bb
recipes/dreambox/dreambox-blindscan-utils.bb
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2.bb
recipes/gstreamer/gst-plugin-dvbmediasink.bb
recipes/libdreamdvd/libdreamdvd.bb
recipes/opkg/opkg-nogpg_svn.bb
recipes/python/python_2.6.4.bb
recipes/sysvinit/sysvinit_2.86.bb
recipes/tuxbox/tuxbox-libtuxtxt.bb
recipes/tuxbox/tuxbox-tuxtxt-32bpp.bb
recipes/udev/udev_124.bb

index a11c9b2,586d5db..443325a
mode 100755,100644..100755
@@@ -3,14 -3,8 +3,14 @@@ LICENSE = "GPL
  
  PR = "r0"
  PV = "0.8+cvs${SRCDATE}"
- SRCDATE = "20100220"
+ SRCDATE = "20101123"
 +
 +PR_vuplus = "r1"
 +PV_vuplus = "0.8cvs${SRCDATE}"
 +SRCDATE_vuplus = "20090625"
  SRC_URI="cvs://anonymous@cvs.schwerkraft.elitedvb.net/cvsroot/aio-grab;module=aio-grab;method=pserver"
 +SRC_URI_append_vuplus = "\
 +      file://aio-grab_vuplus.patch;patch=1"
  
  S = "${WORKDIR}/aio-grab"
  
index ae314ea,1393fdc..749ad26
mode 100755,100644..100755
@@@ -18,12 -18,7 +18,12 @@@ SRC_URI_append_opendreambox = " 
             file://auto.network \
             file://autofs"
  
- PR = "${INC_PR}"
 +SRC_URI_append_vuplus = " \
 +           file://auto.master \
 +           file://auto.network \
 +           file://autofs"
 +
+ PR = "${INC_PR}.1"
  
  inherit update-rc.d
  
@@@ -3,8 -3,7 +3,8 @@@ MAINTAINER = "Felix Domke <tmbinc@elite
  
  PACKAGES_DYNAMIC = "enigma2-plugin-*"
  
- SRCDATE = "20100727"
- SRCDATE_vuplus = "20100727"
+ SRCDATE = "20101112"
++SRCDATE_vuplus = "20101112"
  
  # if you want the 2.7.0 release, use
  #TAG = ";tag=enigma2-plugins_rel27"
@@@ -40,52 -24,9 +40,52 @@@ inherit autotool
  
  S = "${WORKDIR}/enigma2-plugins"
  
- DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen"
+ DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
  DEPENDS += "enigma2"
  
 +
 +def modify_po():
 +      import os
 +      try:
 +              os.system("find ./ -name \"*.po\" > ./po_list")
 +              os.system("find ./ -name \"*.pot\" >> ./po_list")
 +              po_list = []
 +              po_list = open('po_list','r+').readlines()
 +              for x in po_list:
 +                      changeword1(x)
 +              changeword1('enigma2-plugins/networkwizard/src/networkwizard.xml ')
 +              changeword2('enigma2-plugins/webinterface/src/web-data/tpl/default/index.html ')
 +              os.system('rm po_list')
 +      except:
 +              print 'word patch error '
 +              return
 +
 +def changeword1(file):
 +      fn = file[:-1]
 +      fnn = file[:-1]+'_n'
 +      cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
 +      os.system(cmd)
 +      cmd1 = "mv "+fnn+" "+fn
 +      os.system(cmd1)
 +
 +def changeword2(file):
 +      fn = file[:-1]
 +      fnn = file[:-1]+'_n'
 +      cmd = "sed s/Dreambox/Vu+/g "+fn+" > "+fnn
 +      os.system(cmd)
 +      cmd1 = "mv "+fnn+" "+fn
 +      os.system(cmd1)
 +
 +do_unpack_append(){
 +      modify_po()
 +}
 +
 +
 +do_install_append_vuplus() {
 +      install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
 +      install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
 +}
 +
  python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
  
@@@ -26,8 -27,7 +26,9 @@@ RDEPENDS_append_dm800 = " ${GST_BASE_RD
  RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
  RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
  RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
- RDEPENDS_append_vuplus = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
 +RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
++RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
+ RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
  
  # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
  # enigma2 and enigma2-plugins produce enigma2-plugin-*.
@@@ -61,8 -61,7 +62,8 @@@ DESCRIPTION_append_enigma2-plugin-syste
  PN = "enigma2"
  PR = "r0"
  
- SRCDATE = "20100728"
- SRCDATE_vuplus = "20100727"
+ SRCDATE = "20101124"
++SRCDATE_vuplus = "20101124"
  #SRCDATE is NOT used by git to checkout a specific revision
  #but we need it to build a ipk package version
  #when you like to checkout a specific revision of e2 you need
@@@ -82,120 -74,23 +76,128 @@@ PV = "experimental-git${SRCDATE}
  SRCREV = ""
  ####################################################
  
- SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV} \
-       file://new-hotplug.patch;patch=1;pnum=1 \
-       file://enigma2.sh"
 +# if you want a 2.7-based release, use
 +####################################################
 +#BRANCH="2.7"
 +#PV = "2.7git${SRCDATE}"
 +# if you want 2.7.0 use
 +#SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
 +####################################################
 +
 +# if you want a vuplus release, use
 +####################################################
 +#BRANCH_vuplus = "vuplus"
 +#PV_vuplus = "2.8git${SRCDATE}"
 +#SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
 +####################################################
 +
 +#if you want a vuplus experimental, use
 +####################################################
 +BRANCH_vuplus = "vuplus_experimental"
 +PV_vuplus = "experimental-git${SRCDATE}"
 +SRCREV_vuplus = ""
 +####################################################
 +
++
+ SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
  
 +
 +SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
 +         file://enigma2_vuplus_duo.patch;patch=1;pnum=1 \
 +         file://enigma2_vuplus_swloop.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
 +           file://MyriadPro-Regular.otf \
 +           file://MyriadPro-Semibold.otf \
 +           file://MyriadPro-SemiboldIt.otf \
 +           file://750S \
 +           file://Vu_HD \
 +           file://number_key \
 +           file://enigma2.sh"
 +
 +
 +SRC_URI_vusolo = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
 +           file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_misc.patch;patch=1;pnum=1 \
 +           file://MyriadPro-Regular.otf \
 +           file://MyriadPro-Semibold.otf \
 +           file://MyriadPro-SemiboldIt.otf \
 +           file://750S \
 +           file://Vu_HD \
 +           file://number_key \
 +           file://enigma2.sh"
 +
 +def change_po():
 +        import os
 +        try:
 +                os.system("find ./ -name \"*.po\" > ./po_list")
 +                os.system("find ./ -name \"*.pot\" >> ./po_list")
 +                po_list = []
 +                po_list = open('po_list','r+').readlines()
 +                for x in po_list:
 +                        changeword(x)
 +                os.system('rm po_list')
 +        except:
 +                print 'word patch error '
 +                return
 +
 +def changeword(file):
 +        fn = file[:-1]
 +        fnn = file[:-1]+'_n'
 +        cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
 +        os.system(cmd)
 +        cmd1 = "mv "+fnn+" "+fn
 +        os.system(cmd1)
 +
 +do_unpack_append(){
 +        change_po()
 +}
 +
  S = "${WORKDIR}/git"
  
- FILES_${PN} += "${datadir}/fonts"
+ FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
  FILES_${PN}-meta = "${datadir}/meta"
  PACKAGES += "${PN}-meta"
  PACKAGE_ARCH = "${MACHINE_ARCH}"
  
  inherit autotools pkgconfig
  
++<<<<<<< HEAD:recipes/enigma2/enigma2.bb
 +bindir = "/usr/bin"
 +sbindir = "/usr/sbin"
 +
 +EXTRA_OECONF = "--with-target=native --with-libsdl=no"
 +
 +do_compile_prepend_vuplus() {
 +        install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
 +        install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
 +        install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
 +        install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
 +        install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
 +        install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
 +        install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
 +        install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
 +        install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
 +        install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
 +        install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
 +        install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
 +        install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
 +        install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
 +        install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
 +}
 +
 +do_install_append() {
 +      install -m 0755 ${WORKDIR}/enigma2.sh ${D}/usr/bin/
 +}
++=======
+ EXTRA_OECONF = " \
+         BUILD_SYS=${BUILD_SYS} \
+         HOST_SYS=${HOST_SYS} \
+         STAGING_INCDIR=${STAGING_INCDIR} \
+         STAGING_LIBDIR=${STAGING_LIBDIR} \
+ "
++>>>>>>> dm/opendreambox-1.6:recipes/enigma2/enigma2.bb
  
  python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
index 6a98402,dd8df06..52eb996
mode 100755,100644..100755
@@@ -15,12 -15,11 +15,13 @@@ SRC_URI="git://schwerkraft.elitedvb.net
  
  CFLAGS_dm500hd_append = " -DHARDWARE_SUPPORT_LPCM"
  CFLAGS_dm800se_append = " -DHARDWARE_SUPPORT_LPCM"
+ CFLAGS_dm7020hd_append = " -DHARDWARE_SUPPORT_LPCM"
  CFLAGS_dm8000_append = " -DHARDWARE_SUPPORT_LPCM"
  #CFLAGS_dm800_append = " -DHARDWARE_SUPPORT_LPCM"
 +CFLAGS_vusolo_append = " -DHARDWARE_SUPPORT_LPCM"
 +CFLAGS_bm750_append = " -DHARDWARE_SUPPORT_LPCM"
  
- S = "${WORKDIR}/libdreamdvd"
+ S = "${WORKDIR}/git"
  
  inherit autotools pkgconfig
  
index 80c1146,40611a5..f366e3d
mode 100755,100644..100755
@@@ -17,9 -17,10 +17,15 @@@ EXTRA_OECONF += " --disable-gpg 
  LDFLAGS_append = " -Wl,--as-needed"
  
  PV_opendreambox = "0.1.7+svnr${SRCPV}"
- SRC_URI_append_opendreambox = " file://remove_pyc_pyo_hack.patch;patch=1;pnum=1 "
 +PV_vuplus = "0.1.7+svnr${SRCPV}"
- SRC_URI_append_vuplus = " file://remove_pyc_pyo_hack.patch;patch=1;pnum=1 "
+ SRC_URI_append_opendreambox = " \
+       file://remove_pyc_pyo_hack.patch;patch=1 \
+       file://r531-fix-remove.patch;patch=1 \
+ "
++SRC_URI_append_vuplus = " \
++      file://remove_pyc_pyo_hack.patch;patch=1 \
++      file://r531-fix-remove.patch;patch=1 \
++"
  
  # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
  do_configure_prepend() {
@@@ -3,9 -3,8 +3,9 @@@ DEPENDS = "python-native db gdbm openss
             ${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
  DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
  DEPENDS_opendreambox = "python-native db gdbm openssl readline sqlite3 zlib"
 +DEPENDS_vuplus = "python-native db gdbm openssl readline sqlite3 zlib"
  # set to .0 on every increase of INC_PR
- PR = "${INC_PR}.1"
+ PR = "${INC_PR}.2"
  
  SRC_URI = "\
    http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
index 823a3a1,b8a63ce..ef32e26
mode 100755,100644..100755
@@@ -15,10 -15,11 +15,14 @@@ SRC_URI = "cvs://anoncvs@cvs.tuxbox.org
        file://allow_different_demux.diff;patch=1 \
        file://plugin.py"
  
- FILES_${PN} = "/usr/bin/tuxtxt /usr/share/fonts /usr/lib/enigma2/python/Plugins/Extensions/Tuxtxt /etc/tuxtxt"
 +SRC_URI_append_vuplus = " \
 +      file://tuxtxt_vuplus.patch;patch=1;pnum=1"      
 +
+ FILES_${PN} = "/usr/bin/tuxtxt /usr/share/fonts/tuxtxt.otb /usr/lib/enigma2/python/Plugins/Extensions/Tuxtxt /etc/tuxtxt"
+ # tuxtxt.ttf comes from enigma2 git now
+ FILES_${PN}_append_powerpc = " /usr/share/fonts/tuxtxt.ttf"
+ RDEPENDS_${PN}_append_mipsel = " enigma2"
  
  S = "${WORKDIR}/tuxtxt"