Update streamproxy
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi"
7 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
8         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
9         python-pickle gst-plugin-app \
10         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
11         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
12         gst-plugin-wavparse python-netclient gst-plugin-mpegstream gst-plugin-selector \
13         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux \
14         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
15         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect \
16         glibc-gconv-iso8859-15 ethtool"
17
18 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
19 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
20 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-qtdemux gst-plugin-vorbis gst-plugin-audioparsersbad"
21 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
22 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
23
24 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
25 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
27 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30 RDEPENDS_append_vuplus = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
31
32 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
33 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
34 #DEPENDS += "enigma2-plugins"
35 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
36
37 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
38 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
39 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
40 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
41 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
42 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
43 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
44 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
45 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
46 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
47 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
48 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
49 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
50 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
51 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
52 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
53 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
54 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
55 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
56 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
57 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
58 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
59 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
60
61 PN = "enigma2"
62 PR = "r0"
63
64 SRCDATE = "20100728"
65 SRCDATE_vuplus = "20100727"
66 #SRCDATE is NOT used by git to checkout a specific revision
67 #but we need it to build a ipk package version
68 #when you like to checkout a specific revision of e2 you need
69 #have to specify a commit id or a tag name in SRCREV
70
71 # if you want upcoming release, use:
72 ####################################################
73 #BRANCH = "master"
74 #PV = "2.8git${SRCDATE}"
75 #SRCREV = ""
76 ####################################################
77
78 # if you want experimental use
79 ####################################################
80 BRANCH = "experimental"
81 PV = "experimental-git${SRCDATE}"
82 SRCREV = ""
83 ####################################################
84
85 # if you want a 2.7-based release, use
86 ####################################################
87 #BRANCH="2.7"
88 #PV = "2.7git${SRCDATE}"
89 # if you want 2.7.0 use
90 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
91 ####################################################
92
93 # if you want a vuplus release, use
94 ####################################################
95 #BRANCH_vuplus = "vuplus"
96 #PV_vuplus = "2.8git${SRCDATE}"
97 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
98 ####################################################
99
100 #if you want a vuplus experimental, use
101 ####################################################
102 BRANCH_vuplus = "vuplus_experimental"
103 PV_vuplus = "experimental-git${SRCDATE}"
104 SRCREV_vuplus = ""
105 ####################################################
106
107 SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV} \
108         file://new-hotplug.patch;patch=1;pnum=1 \
109         file://enigma2.sh"
110
111
112 SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
113            file://enigma2_vuplus_duo.patch;patch=1;pnum=1 \
114            file://enigma2_vuplus_swloop.patch;patch=1;pnum=1 \
115            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
116            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
117            file://MyriadPro-Regular.otf \
118            file://MyriadPro-Semibold.otf \
119            file://MyriadPro-SemiboldIt.otf \
120            file://750S \
121            file://Vu_HD \
122            file://number_key \
123            file://enigma2.sh"
124
125
126 SRC_URI_vusolo = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
127            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
128            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
129            file://enigma2_vuplus_misc.patch;patch=1;pnum=1 \
130            file://MyriadPro-Regular.otf \
131            file://MyriadPro-Semibold.otf \
132            file://MyriadPro-SemiboldIt.otf \
133            file://750S \
134            file://Vu_HD \
135            file://number_key \
136            file://enigma2.sh"
137
138 def change_po():
139         import os
140         try:
141                 os.system("find ./ -name \"*.po\" > ./po_list")
142                 os.system("find ./ -name \"*.pot\" >> ./po_list")
143                 po_list = []
144                 po_list = open('po_list','r+').readlines()
145                 for x in po_list:
146                         changeword(x)
147                 os.system('rm po_list')
148         except:
149                 print 'word patch error '
150                 return
151
152 def changeword(file):
153         fn = file[:-1]
154         fnn = file[:-1]+'_n'
155         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
156         os.system(cmd)
157         cmd1 = "mv "+fnn+" "+fn
158         os.system(cmd1)
159
160 do_unpack_append(){
161         change_po()
162 }
163
164 S = "${WORKDIR}/git"
165
166 FILES_${PN} += "${datadir}/fonts"
167 FILES_${PN}-meta = "${datadir}/meta"
168 PACKAGES += "${PN}-meta"
169 PACKAGE_ARCH = "${MACHINE_ARCH}"
170
171 inherit autotools pkgconfig
172
173 bindir = "/usr/bin"
174 sbindir = "/usr/sbin"
175
176 EXTRA_OECONF = "--with-target=native --with-libsdl=no"
177
178 do_compile_prepend_vuplus() {
179         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
180         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
181         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
182         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
183         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
184         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
185         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
186         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
187         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
188         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
189         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
190         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
191         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
192         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
193         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
194 }
195
196 do_install_append() {
197         install -m 0755 ${WORKDIR}/enigma2.sh ${D}/usr/bin/
198 }
199
200 python populate_packages_prepend () {
201         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
202
203         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
204 }
205
206 do_stage() {
207         install -d ${STAGING_INCDIR}/enigma2
208         install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/enigma2
209         for dir in actions base components driver dvb dvb/lowlevel dvb_ci gdi gui mmi nav python service; do
210                 install -d ${STAGING_INCDIR}/enigma2/lib/$dir;
211                 install -m 0644 ${S}/lib/$dir/*.h ${STAGING_INCDIR}/enigma2/lib/$dir;
212         done
213 }