opera hbbtv.
authorkos <kos@dev3>
Fri, 24 Aug 2012 02:51:45 +0000 (11:51 +0900)
committerkos <kos@dev3>
Fri, 24 Aug 2012 02:51:45 +0000 (11:51 +0900)
   - upgrade libdvbsi++ package.
   - include hbbtv plugin.
   - packaging opera-hbbtv binutil.

recipes/enigma2/enigma2.bb
recipes/opera-hbbtv/opera-hbbtv_0.1.bb [new file with mode: 0644]
recipes/tasks/task-vuplus-enigma2.bb
recipes/tuxbox/libdvbsi++.bb

index 119707a..70b4aee 100644 (file)
@@ -4,7 +4,7 @@ DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        dreambox-dvbincludes freetype libdvbsi++ python swig-native \
        libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
        gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data \
-       hostap-daemon bridge-utils djmount minidlna "
+       hostap-daemon bridge-utils djmount minidlna mpfr gmp tslib opera-hbbtv"
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
        python-pickle gst-plugin-app gst-plugin-fragmented \
@@ -71,9 +71,10 @@ RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridg
 RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugin-rtmp "
 RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount fuse-utils libfuse2 libupnp3 kernel-module-fuse "
 RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna libexif12 libavformat52 libavutil50 libavcodec52 libgsm1 libmp3lame0 libschroedinger-1.0-0 libtheora0 liboil"
+RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 directfb libgmp3 libmpfr1 opera-hbbtv"
 
 PN = "enigma2"
-PR = "r39"
+PR = "r40"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
diff --git a/recipes/opera-hbbtv/opera-hbbtv_0.1.bb b/recipes/opera-hbbtv/opera-hbbtv_0.1.bb
new file mode 100644 (file)
index 0000000..60012da
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "opera-hbbtv"
+PRIORITY = "required"
+
+SRC_DATE = 20120824
+
+PR = "r0_${SRC_DATE}"
+SRC_URI = "http://code.vuplus.com/download/build.fc3abf29fb03f797e78f907928125638/embedded/opera-sdk-build-package/opera-hbbtv_${SRC_DATE}.tar.gz"
+
+INHIBIT_PACKAGE_STRIP = "1"
+S = "${WORKDIR}/opera-hbbtv"
+do_compile() {
+}
+do_install() {
+        install -d ${D}/usr/local/hbb-browser
+       mv ${S}/opera/* ${D}/usr/local/hbb-browser/
+        install -d ${D}/etc
+       mv ${S}/dfb/etc/* ${D}/etc/
+        install -d ${D}/usr/bin
+       mv ${S}/dfb/usr/bin/* ${D}/usr/bin/
+        install -d ${D}/usr/lib
+       mv ${S}/dfb/usr/lib/* ${D}/usr/lib/
+        install -d ${D}/usr/share
+       mv ${S}/dfb/usr/share/* ${D}/usr/share/
+}
+
+PACKAGES = ${PN}
+
+FILES_${PN} = "/"
+
index 0dcde73..c49ea97 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Vuplus: E2 Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
-PR = "r21"
+PR = "r22"
 
 inherit task
 
@@ -60,8 +60,7 @@ RRECOMMENDS_task-vuplus-enigma2 = "\
 
 RDEPENDS_task-vuplus-enigma2_append_bm750 = "\
   enigma2-plugin-systemplugins-fancontrol \
-  vuplus-webbrowser-utils \
-  enigma2-plugin-extensions-webbrowser \
+  enigma2-plugin-extensions-hbbtv \
 "
 
 RDEPENDS_task-vuplus-enigma2_append_vuuno = "\
@@ -69,8 +68,7 @@ RDEPENDS_task-vuplus-enigma2_append_vuuno = "\
   enigma2-plugin-systemplugins-blindscan \
   enigma2-plugin-systemplugins-manualfancontrol \
   enigma2-plugin-systemplugins-remotecontrolcode \
-  vuplus-webbrowser-utils \
-  enigma2-plugin-extensions-webbrowser \
+  enigma2-plugin-extensions-hbbtv \
 "
 RDEPENDS_task-vuplus-enigma2_append_vuultimo = "\
   enigma2-plugin-systemplugins-firmwareupgrade \
@@ -78,8 +76,7 @@ RDEPENDS_task-vuplus-enigma2_append_vuultimo = "\
   enigma2-plugin-systemplugins-manualfancontrol \
   enigma2-plugin-systemplugins-remotecontrolcode \
   enigma2-plugin-systemplugins-ledbrightnesssetup \
-  vuplus-webbrowser-utils \
-  enigma2-plugin-extensions-webbrowser \
+  enigma2-plugin-extensions-hbbtv \
 "
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
index ecdf416..542383a 100644 (file)
@@ -2,13 +2,15 @@ DESCRIPTION = "libdvbsi++ by obi@saftware.de"
 DEPENDS = "dreambox-dvbincludes"
 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
 
-SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox;module=apps/dvb/libdvbsi++;method=ext"
+SRC_URI = "git://git.opendreambox.org/git/obi/libdvbsi++.git;protocol=git"
 
-SRCDATE = "20090224"
-PR = "r0"
-PV = "0.0+cvs${SRCDATE}"
+SRCREV = "49b0c78a0b0db3efd0a49c4cf2fc1c7f4bf21c15"
 
-S = "${WORKDIR}/libdvbsi++"
+PV = "1.0+git${SRCPV}"
+PKGV = "1.0+git${GITPKGV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig