opera hbbtv.
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data \
7         hostap-daemon bridge-utils djmount minidlna mpfr gmp tslib opera-hbbtv"
8 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
9         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
10         python-pickle gst-plugin-app gst-plugin-fragmented \
11         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
12         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
13         gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
14         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
15         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
16         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect gst-plugin-flv \
17         glibc-gconv-iso8859-15 ethtool"
18
19 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
20 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
21 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-isomp4 gst-plugin-vorbis gst-plugin-audioparsers"
22 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
23 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
24
25 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
27 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30 RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
31 RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
32 RDEPENDS_append_vuuno = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
33 RDEPENDS_append_vuultimo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
34 RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
35
36 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
37 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
38 #DEPENDS += "enigma2-plugins"
39 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
40
41 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
42 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
43 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
44 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
45 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
46 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
47 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
48 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
49 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
50 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
51 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
52 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
53 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
54 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
55 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
56 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
57 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
58 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
59 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
60 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
61 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
62 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
63 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
64 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
65 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
66 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
67 DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
68 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
69 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usbmodeswitch usbmodeswitch-data wvdial wvstreams libwvutils4.6 libwvstreams-extras libuniconf4.6"
70 RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
71 RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugin-rtmp "
72 RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount fuse-utils libfuse2 libupnp3 kernel-module-fuse "
73 RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna libexif12 libavformat52 libavutil50 libavcodec52 libgsm1 libmp3lame0 libschroedinger-1.0-0 libtheora0 liboil"
74 RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 directfb libgmp3 libmpfr1 opera-hbbtv"
75
76 PN = "enigma2"
77 PR = "r40"
78
79 SRCDATE = "20110922"
80 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
81 #SRCDATE is NOT used by git to checkout a specific revision
82 #but we need it to build a ipk package version
83 #when you like to checkout a specific revision of e2 you need
84 #have to specify a commit id or a tag name in SRCREV
85
86 # if you want experimental use
87 ####################################################
88 BRANCH = "experimental"
89 PV = "experimental-git${SRCDATE}"
90 #SRCREV = ""
91 ####################################################
92
93 # if you want a 2.7-based release, use
94 ####################################################
95 #BRANCH="2.7"
96 #PV = "2.7git${SRCDATE}"
97 # if you want 2.7.0 use
98 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
99 ####################################################
100
101 # if you want a vuplus release, use
102 ####################################################
103 #BRANCH_vuplus = "vuplus"
104 #PV_vuplus = "2.8git${SRCDATE}"
105 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
106 ####################################################
107
108 #if you want a vuplus experimental, use
109 ####################################################
110 BRANCH_vuplus = "vuplus_experimental"
111 PV_vuplus = "experimental-git${SRCDATE}"
112 SRCREV_vuplus = ""
113 ####################################################
114
115 #SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
116 #SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
117
118 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
119
120
121 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
122            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
123            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
124            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
125            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
126            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
127            file://MyriadPro-Regular.otf \
128            file://MyriadPro-Semibold.otf \
129            file://MyriadPro-SemiboldIt.otf \
130            file://750S \
131            file://Vu_HD \
132            file://number_key \
133            "
134
135 SRC_URI_append_bm750 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
136 SRC_URI_append_vuuno = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
137
138 SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
139
140 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
141
142 SRC_URI_append_vuultimo = " \
143            file://analog.ttf \
144            file://skin_user.xml \
145            file://vfd_icons \
146 "
147
148 def change_po():
149         import os
150         try:
151                 os.system("find ./ -name \"*.po\" > ./po_list")
152                 os.system("find ./ -name \"*.pot\" >> ./po_list")
153                 po_list = []
154                 po_list = open('po_list','r+').readlines()
155                 for x in po_list:
156                         changeword(x)
157                 os.system('rm po_list')
158         except:
159                 print 'word patch error '
160                 return
161
162 def changeword(file):
163         fn = file[:-1]
164         fnn = file[:-1]+'_n'
165         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
166         os.system(cmd)
167         cmd1 = "mv "+fnn+" "+fn
168         os.system(cmd1)
169
170 do_unpack_append(){
171         change_po()
172 }
173
174 S = "${WORKDIR}/git"
175
176 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
177 FILES_${PN}-meta = "${datadir}/meta"
178 PACKAGES += "${PN}-meta"
179 PACKAGE_ARCH = "${MACHINE_ARCH}"
180
181 inherit autotools pkgconfig
182
183
184 do_compile_prepend_vuplus() {
185         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
186         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
187         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
188         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
189         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
190         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
191         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
192         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
193         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
194         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
195         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
196         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
197         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
198         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
199         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
200 }
201
202 EXTRA_OECONF = " \
203         ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
204         ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
205         ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
206         ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
207         BUILD_SYS=${BUILD_SYS} \
208         HOST_SYS=${HOST_SYS} \
209         STAGING_INCDIR=${STAGING_INCDIR} \
210         STAGING_LIBDIR=${STAGING_LIBDIR} \
211 "
212
213 do_install_append_vuultimo() {
214         install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
215         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
216         install -d ${D}/usr/share/enigma2/vfd_icons/
217         install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
218 }
219
220 python populate_packages_prepend () {
221         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
222
223         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
224 }
225
226 RCONFLICTS_${PN} = "dreambox-keymaps"
227 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
228
229 # workaround for opkg <= 0.1.7+svnr455-r19.1
230 pkg_preinst_${PN} () {
231         if [ "x$D" != "x" ]; then
232                 exit 1
233         fi
234         if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
235                 cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
236         fi
237 }
238 pkg_postinst_${PN} () {
239         if [ "x$D" != "x" ]; then
240                 exit 1
241         fi
242         if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
243                 mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
244         fi
245 }