opera hbbtv.
[vuplus_openembedded] / recipes / wvstreams / wvstreams_4.4.1.bb
1 HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
2 LICENSE = "LGPL"
3 DESCRIPTION = "WvStreams is a network programming library in C++"
4 DEPENDS = "zlib openssl (>= 0.9.8)"
5
6 PR = "r3"
7
8 SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
9         file://build-fixes-and-sanity.patch;patch=1 \
10         file://dont-forget-header.patch;patch=1 \
11         file://gcc4.3.patch;patch=1 \
12         "
13
14
15 inherit autotools pkgconfig
16
17 LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
18
19 EXTRA_AUTORECONF += " -I${S}/gnulib/m4"
20 EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
21
22 PACKAGES_prepend = "libuniconf libuniconf-dbg "
23 PACKAGES_prepend = "uniconfd uniconfd-dbg "
24 PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
25 PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
26
27 FILES_libuniconf     = "${libdir}/libuniconf.so.*"
28 FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
29
30 FILES_uniconfd     = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
31 FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
32
33 FILES_libwvstreams-base     = "${libdir}/libwvutils.so.*"
34 FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
35
36 FILES_libwvstreams-extras     = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
37 FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"
38
39
40 do_stage() {
41     autotools_stage_all
42 }