opera hbbtv.
[vuplus_openembedded] / recipes / slugimage / slugimage.bb
1 # slugimage - normally built native, a perl script
2 SECTION = "console/utils"
3 LICENSE = "BSD"
4 DESCRIPTION = "Slugimage is a small app to disassemble and reassemble \
5 flash images for the Linksys NSLU2 device. It also has jffs2 support"
6 PR = "r12"
7
8 RDEPENDS = "perl"
9
10 SLUGIMAGE_SVN_REV  ?= "104"
11 SLUGIMAGE_SVN_REPO ?= "http://svn.nslu2-linux.org/svnroot/slugimage/trunk"
12
13 addtask svnfetch before do_configure after do_patch
14
15 do_svnfetch() {
16         svn co ${SLUGIMAGE_SVN_REPO} --revision ${SLUGIMAGE_SVN_REV} ${WORKDIR}
17 }
18
19 S = "${WORKDIR}"
20
21 do_install () {
22         install -d ${D}${bindir}
23         install -m 0755 slugimage ${D}${bindir}/
24 }