opera hbbtv.
[vuplus_openembedded] / recipes / qpf-fonts / qpf-qte_2.3.10.bb
1 require qpf.inc
2
3 DESCRIPTION = "Qt/Embedded fonts version ${PV}"
4 HOMEPAGE = "http://www.trolltech.com"
5 LICENSE = "GPL QPL"
6 PR = "r2"
7
8 PROVIDES  = "qte-font-helvetica-100 qte-font-helvetica-120"
9 PROVIDES += "qte-font-fixed-70 qte-font-fixed-120"
10 PROVIDES += "qte-font-helvetica-80 qte-font-helvetica-140 qte-font-helvetica-180 qte-font-helvetica-240"
11 PROVIDES += "qte-font-smallsmooth-90"
12 PROVIDES += "qte-font-micro-40"
13 PROVIDES += "qte-font-japanese-230"
14 PROVIDES += "qte-font-smoothmono-90 qte-font-smoothmono-100  qte-font-smoothmono-110 qte-font-smoothmono-120"
15 PROVIDES += "qte-font-smoothmono-140 qte-font-smoothmono-180  qte-font-smoothmono-240"
16 PROVIDES += "qte-font-smoothsans-90 qte-font-smoothsans-100  qte-font-smoothsans-110 qte-font-smoothsans-120"
17 PROVIDES += "qte-font-smoothsans-140 qte-font-smoothsans-180  qte-font-smoothsans-240"
18 PROVIDES += "qte-font-smoothserif-90 qte-font-smoothserif-100  qte-font-smoothserif-110 qte-font-smoothserif-120"
19 PROVIDES += "qte-font-smoothserif-140 qte-font-smoothserif-180  qte-font-smoothserif-240"
20 PROVIDES += "qte-font-smoothtimes-100  qte-font-smoothtimes-160 qte-font-smoothtimes-170"
21 PROVIDES += "qte-font-smoothtimes-220 qte-font-smoothtimes-250  qte-font-smoothtimes-440"
22 PROVIDES += "qte-font-unifont"
23 RPROVIDES_qte-font-unifont += "virtual-japanese-font"
24 RPROVIDES_qte-font-japanese += "virtual-japanese-font"
25
26 SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz"
27 S = "${WORKDIR}/qt-${PV}"
28
29 QPF_PKGPATTERN = "qte-font-%s"
30 QPF_DESCRIPTION = "Qt/E font %s"
31
32 do_install() {
33         install -d ${D}${palmqtdir}/lib/fonts/
34         cp -pPR lib/fonts/* ${D}${palmqtdir}/lib/fonts/
35 }