opera hbbtv.
[vuplus_openembedded] / recipes / pmacct / pmacct_0.7.9.bb
1 DESCRIPTION = "Promiscuous mode IP Accounting package"
2 HOMEPAGE = "http://www.ba.cnr.it/~paolo/pmacct/"
3 LICENSE = "GPLv2"
4 DEPENDS = "libpcap"
5 PR = "r2"
6
7 SRC_URI = "http://www.ba.cnr.it/~paolo/pmacct/pmacct-${PV}.tar.gz \
8         file://pmacct.init \
9         file://pmacct.conf.eth0"
10
11 inherit autotools
12
13 # Without this it'll check for the headers in /usr/include
14 EXTRA_OECONF = "--with-pcap-includes=${STAGING_INCDIR}"
15
16 do_configure () {
17         oe_runconf
18 }
19
20 do_install() {
21         autotools_do_install
22         install -d ${D}${sysconfdir}/init.d/
23         install -d ${D}${sysconfdir}/pmacct
24         install -m 755 ${WORKDIR}/pmacct.init ${D}${sysconfdir}/init.d/pmacct
25         install -m 644 ${WORKDIR}/pmacct.conf.eth0 ${D}${sysconfdir}/pmacct
26 }
27
28 CONFFILES_${PN}_nylon = "${sysconfdir}/pmacct/pmacct.conf.eth0"