Merge commit 'dm/opendreambox-1.6' into test_0310
[vuplus_openembedded] / recipes / opkg / opkg-nogpg_svn.bb
1 require opkg_svn.bb
2
3 DEPENDS = "curl"
4 PROVIDES += "opkg"
5
6 PR = "${INC_PR}.4"
7
8 SRCREV = "${SRCREV_pn-opkg}"
9
10 EXTRA_OECONF += " --disable-gpg \ 
11                   --disable-openssl \ 
12                   --disable-ssl-curl \
13                   --enable-gpg=no \
14                   --enable-ssl-curl=no \
15                   --enable-openssl=no"
16
17 LDFLAGS_append = " -Wl,--as-needed"
18
19 PV_opendreambox = "0.1.7+svnr${SRCPV}"
20 PV_vuplus = "0.1.7+svnr${SRCPV}"
21 SRC_URI_append_opendreambox = " \
22         file://remove_pyc_pyo_hack.patch;patch=1 \
23         file://r531-fix-remove.patch;patch=1 \
24         file://r599-fix-depmod.patch;patch=1 \
25 "
26 SRC_URI_append_vuplus = " \
27         file://remove_pyc_pyo_hack.patch;patch=1 \
28         file://r531-fix-remove.patch;patch=1 \
29 "
30
31 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
32 do_configure_prepend() {
33         sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
34 }
35 do_configure_prepend_nylon() {
36         LDFLAGS="`echo "$LDFLAGS" | sed "s/ -Wl,--as-needed//"`"
37 }
38
39 DEFAULT_PREFERENCE = "-1"