Merge commit 'dm/opendreambox-1.6' into test_0310
authorschon <schon@dev03-server>
Thu, 10 Mar 2011 04:51:16 +0000 (13:51 +0900)
committerschon <schon@dev03-server>
Thu, 10 Mar 2011 04:51:16 +0000 (13:51 +0900)
Conflicts:
recipes/autofs/autofs_4.1.4.bb
recipes/busybox/busybox_1.15.3.bb
recipes/enigma2/enigma2.bb
recipes/gstreamer/gst-plugin-dvbmediasink.bb
recipes/tasks/task-boot.bb
recipes/udev/udev_124.bb

1  2 
recipes/autofs/autofs_4.1.4.bb
recipes/busybox/busybox_1.15.3.bb
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2.bb
recipes/gstreamer/gst-plugin-dvbmediasink.bb
recipes/gstreamer/gst-plugins.inc
recipes/libdreamdvd/libdreamdvd.bb
recipes/opkg/opkg-nogpg_svn.bb
recipes/udev/udev_124.bb
recipes/vsftpd/vsftpd_2.0.5.bb

index 749ad26,2581e9e..30ae94c
mode 100755,100644..100755
@@@ -18,12 -18,7 +18,12 @@@ SRC_URI_append_opendreambox = " 
             file://auto.network \
             file://autofs"
  
- PR = "${INC_PR}.1"
 +SRC_URI_append_vuplus = " \
 +           file://auto.master \
 +           file://auto.network \
 +           file://autofs"
 +
+ PR = "${INC_PR}.2"
  
  inherit update-rc.d
  
Simple merge
@@@ -62,8 -61,8 +62,9 @@@ DESCRIPTION_append_enigma2-plugin-syste
  PN = "enigma2"
  PR = "r0"
  
- SRCDATE = "20101204"
- SRCDATE_vuplus = "20101204"
+ SRCDATE = "20110217"
++SRCDATE_vuplus = "20110217"
+ SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
  #SRCDATE is NOT used by git to checkout a specific revision
  #but we need it to build a ipk package version
  #when you like to checkout a specific revision of e2 you need
  ####################################################
  BRANCH = "experimental"
  PV = "experimental-git${SRCDATE}"
- SRCREV = ""
#SRCREV = ""
  ####################################################
  
 +# if you want a 2.7-based release, use
 +####################################################
 +#BRANCH="2.7"
 +#PV = "2.7git${SRCDATE}"
 +# if you want 2.7.0 use
 +#SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
 +####################################################
 +
 +# if you want a vuplus release, use
 +####################################################
 +#BRANCH_vuplus = "vuplus"
 +#PV_vuplus = "2.8git${SRCDATE}"
 +#SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
 +####################################################
 +
 +#if you want a vuplus experimental, use
 +####################################################
 +BRANCH_vuplus = "vuplus_experimental"
 +PV_vuplus = "experimental-git${SRCDATE}"
 +SRCREV_vuplus = ""
 +####################################################
 +
 +
  SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
+ SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
  
 +
 +SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
 +         file://enigma2_vuplus_duo.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
 +           file://MyriadPro-Regular.otf \
 +           file://MyriadPro-Semibold.otf \
 +           file://MyriadPro-SemiboldIt.otf \
 +           file://750S \
 +           file://Vu_HD \
 +           file://number_key \
 +           "
 +
 +
 +SRC_URI_vusolo = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
 +           file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
 +           file://enigma2_vuplus_misc.patch;patch=1;pnum=1 \
 +           file://MyriadPro-Regular.otf \
 +           file://MyriadPro-Semibold.otf \
 +           file://MyriadPro-SemiboldIt.otf \
 +           file://750S \
 +           file://Vu_HD \
 +           file://number_key \
 +           "
 +
 +def change_po():
 +        import os
 +        try:
 +                os.system("find ./ -name \"*.po\" > ./po_list")
 +                os.system("find ./ -name \"*.pot\" >> ./po_list")
 +                po_list = []
 +                po_list = open('po_list','r+').readlines()
 +                for x in po_list:
 +                        changeword(x)
 +                os.system('rm po_list')
 +        except:
 +                print 'word patch error '
 +                return
 +
 +def changeword(file):
 +        fn = file[:-1]
 +        fnn = file[:-1]+'_n'
 +        cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
 +        os.system(cmd)
 +        cmd1 = "mv "+fnn+" "+fn
 +        os.system(cmd1)
 +
 +do_unpack_append(){
 +        change_po()
 +}
 +
  S = "${WORKDIR}/git"
  
  FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
@@@ -3,19 -3,18 +3,21 @@@ SECTION = "multimedia
  PRIORITY = "optional"
  MAINTAINER = "Felix Domke <tmbinc@openembedded.org>"
  DEPENDS = "gstreamer gst-plugins-base"
- PV = "0.10+cvs${SRCDATE}"
- PR = "r1"
  
- inherit autotools pkgconfig
+ SRCREV="15a323fd769d4546bc454bfd81848aa43d655f3d"
+ SRCDATE="20110210"
+ BRANCH="master"
+ PV = "0.10+git${SRCDATE}"
+ PR = "r0"
  
- SRCDATE = "20101106"
+ inherit autotools pkgconfig
  
- SRC_URI = "cvs://anonymous@cvs.schwerkraft.elitedvb.net/cvsroot/dvbmediasink;module=dvbmediasink;method=pserver"
+ SRC_URI = "git://schwerkraft.elitedvb.net/dvbmediasink/dvbmediasink.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
  
- S = "${WORKDIR}/dvbmediasink"
 +SRC_URI_append_vuplus = " \
 +              file://fix_dvbaudiosink_async_opt.patch;patch=1;pnum=1"
 +
+ S = "${WORKDIR}/git"
  
  FILES_${PN} = "${libdir}/gstreamer-0.10/*.so*"
  FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la \
index 228af90,de036cf..d37f901
mode 100755,100644..100755
@@@ -3,9 -3,8 +3,9 @@@ DESCRIPTION = "Plugins for GStreamer
  DEPENDS = "gstreamer libmikmod liboil libogg tremor libvorbis"
  DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
  DEPENDS += "${@base_conditional('DISTRO', 'opendreambox', 'libmad libsoup-2.4 flac libmatroska libcdio libid3tag', '', d)}"
 +DEPENDS += "${@base_conditional('DISTRO', 'vuplus', 'libmad libsoup-2.4 flac libmatroska libcdio libid3tag', '', d)}"
  
- INC_PR = "r1"
+ INC_PR = "r0"
  
  PACKAGES_DYNAMIC = "gst-plugin-*"
  
index f366e3d,781f428..c7d59be
mode 100755,100644..100755
@@@ -21,11 -20,8 +21,12 @@@ PV_vuplus = "0.1.7+svnr${SRCPV}
  SRC_URI_append_opendreambox = " \
        file://remove_pyc_pyo_hack.patch;patch=1 \
        file://r531-fix-remove.patch;patch=1 \
+       file://r599-fix-depmod.patch;patch=1 \
  "
 +SRC_URI_append_vuplus = " \
 +      file://remove_pyc_pyo_hack.patch;patch=1 \
 +      file://r531-fix-remove.patch;patch=1 \
 +"
  
  # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
  do_configure_prepend() {