opera hbbtv.
[vuplus_openembedded] / recipes / mini-httpd / mini-httpd_1.19.bb
1 # Copyright (C) 2009 Khem Raj <raj.khem@gmail.org>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "mini_httpd is a small HTTP server. \
5                It implements all the basic features of an HTTP server \
6                It can also be configured to do SSL/HTTPS and IPv6. \
7                "
8 HOMEPAGE = "http://www.acme.com/software/mini_httpd/"
9 LICENSE = "BSD"
10 SECTION = "net"
11 DEPENDS = "openssl"
12 PR = "r0"
13
14 SRC_URI="http://www.acme.com/software/mini_httpd/mini_httpd-${PV}.tar.gz \
15          file://new-bindir-mandir.patch;patch=1 \
16          file://remove-CC.patch;patch=1 \
17          file://mini-httpd.conf \
18          file://init \
19         "
20
21 INITSCRIPT_NAME = "mini_httpd"
22 INITSCRIPT_PARAMS = "defaults"
23
24 S = "${WORKDIR}/mini_httpd-${PV}"
25
26
27 inherit autotools update-rc.d
28
29 do_install () {
30         install -d ${D}${sysconfdir}
31         install -d ${D}${sysconfdir}/init.d
32         install -d ${D}${sysconfdir}/mini-httpd
33         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/mini_httpd
34         install -m 0755 ${WORKDIR}/mini-httpd.conf ${D}${sysconfdir}/mini-httpd.conf
35         oe_runmake 'BINDIR=${D}${sbindir}' 'MANDIR=${D}${mandir}' install
36 }