opera hbbtv.
[vuplus_openembedded] / recipes / libdvdnav / libdvdnav_git.bb
1 # libdvdnav.bb build file
2 HOMEPAGE="http://git.debian-maintainers.org/"
3 DESCRIPTION="DVD navigation multimeda library"
4 LICENSE = "GPL"
5 DEPENDS = "libdvdread"
6 RDEPENDS = "libdvdread"
7
8 PV = "4.1.3+git"
9 PR = "r8"
10
11 #debian/4.1.3-7
12 SRCREV="850e513d4fea29b40879378b13003cd677e5214b"
13
14 EXTRA_OECONF = "--with-dvdread-prefix=${STAGING_LIBDIR}/.."
15
16 SRC_URI = "git://git.debian-maintainers.org/git/daniel/libdvdnav.git;protocol=git;branch=debian \
17         file://dvdnav-fix-random-shuffle-titles.patch;patch=1;pnum=1"
18
19 S = "${WORKDIR}/git"
20
21 inherit autotools pkgconfig
22
23 do_munge() {
24         for i in `ls debian/patches | grep ".patch" | sort -n`; do
25                 oenote "Applying debian patch '$i'";
26                 patch -p1 < debian/patches/$i;
27         done;
28 }
29
30 addtask munge before do_compile after do_patch
31
32 do_stage() {
33         autotools_stage_all
34 }