opera hbbtv.
[vuplus_openembedded] / recipes / cdparanoia / cdparanoia_svn.bb
1 # cdparanoia OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 PR ="r1"
6 LICENSE="GPL"
7
8 PV = "10.2+svnr${SRCPV}"
9
10 SRC_URI="svn://svn.xiph.org/trunk;module=cdparanoia;proto=http \
11          file://fixes10.patch;patch=1 \
12          file://Makefile.in.patch;patch=1 \
13          file://interface_Makefile.in.patch;patch=1 \
14          file://paranoia_Makefile.in.patch;patch=1 \
15          file://configure.in.patch;patch=1 "
16
17 S="${WORKDIR}/cdparanoia"
18
19 PARALLEL_MAKE = ""
20
21 inherit autotools
22
23 do_install() {
24         oe_runmake BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man/" \
25                    INCLUDEDIR="${D}/usr/include/" LIBDIR="${D}/usr/lib" install
26 }
27
28 do_stage() {
29         install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}
30
31         install -m 0644 paranoia/cdda_paranoia.h ${STAGING_INCDIR}
32         install -m 0644 interface/cdda_interface.h ${STAGING_INCDIR}
33
34         oe_libinstall -C interface libcdda_interface ${STAGING_LIBDIR}
35         oe_libinstall -C paranoia libcdda_paranoia ${STAGING_LIBDIR}
36 }