opera hbbtv.
[vuplus_openembedded] / recipes / cdparanoia / cdparanoia_10.2.bb
1 # cdparanoia OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4 LICENSE = "GPL"
5
6 SRC_URI = "http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-10.2.src.tgz \
7          file://fixes10.patch;patch=1 \
8          file://Makefile.in.patch;patch=1 \
9          file://interface_Makefile.in.patch;patch=1 \
10          file://paranoia_Makefile.in.patch;patch=1 \
11          file://cdparanoia-III-10.2-privatefix.patch;patch=1 \
12          file://configure.in.patch;patch=1"
13
14 S = "${WORKDIR}/cdparanoia-III-10.2"
15
16 inherit autotools
17
18 PARALLEL_MAKE = ""
19
20 do_install() {
21         oe_runmake BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man/" \
22                    INCLUDEDIR="${D}/usr/include/" LIBDIR="${D}/usr/lib" install
23 }
24
25 do_stage() {
26         install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}
27         install -m 0644 paranoia/cdda_paranoia.h ${STAGING_INCDIR}
28         install -m 0644 interface/cdda_interface.h ${STAGING_INCDIR}
29         oe_libinstall -C interface libcdda_interface ${STAGING_LIBDIR}
30         oe_libinstall -C paranoia libcdda_paranoia ${STAGING_LIBDIR}
31 }
32