opera hbbtv.
[vuplus_openembedded] / recipes / avr-libc / avr-libc_1.0.3.bb
1 HOMEPAGE = "http://www.nongnu.org/avr-libc"
2 DESCRIPTION = "C library for use with GCC on Atmel AVR microcontrollers"
3 PROVIDES = "virtual/libc"
4 SECTION = "libs"
5 LICENSE = "BSD"
6
7 python __anonymous () {
8     import bb, re
9     if (re.match('avr', bb.data.getVar('TARGET_ARCH', d, 1)) == None):
10         raise bb.parse.SkipPackage("incompatible with arch %s" %
11                                    bb.data.getVar('TARGET_ARCH', d, 1))
12 }
13
14 SRC_URI = "http://savannah.nongnu.org/download/avr-libc/avr-libc-${PV}.tar.bz2 \
15            file://configure.patch;patch=1"
16 B = "${WORKDIR}/build.${BUILD_SYS}.${TARGET_SYS}"
17
18 inherit autotools
19
20 export tooldir = "${prefix}"
21 prefix = "${CROSS_DIR}"
22 exec_prefix = "${prefix}"
23
24 do_stage () {
25         # install into CROSS_DIR
26         oe_runmake install
27         # install into staging
28         oe_runmake "prefix=${STAGING_DIR_HOST}${layout_prefix}" \
29                    "exec_prefix=${STAGING_DIR_HOST}${layout_exec_prefix}" \
30                    "bindir=${STAGING_BINDIR}" "libdir=${STAGING_LIBDIR}" \
31                    "tooldir=${STAGING_DIR_HOST}" "toolibdir=${STAGING_LIBDIR}" \
32                    install
33 }
34
35 do_install () {
36 # install into D
37         oe_runmake "DESTDIR=${D}" "tooldir=/" install
38 }