Fix/update bb files.
[vuplus_openembedded] / recipes / autofs / autofs_4.1.4.bb
1 require autofs.inc
2
3 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
4            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
5            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
6            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
7            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-locking-fix-1.patch;patch=1 \
8            file://cross.patch;patch=1 \
9            file://Makefile.rules-cross.patch;patch=1 \
10            file://install.patch;patch=1 \
11            file://auto.net-sort-option-fix.patch;patch=1 \
12            file://autofs-additional-distros.patch;patch=1 \
13            file://no-bash.patch;patch=1 \
14            file://autofs-add-hotplug.patch;patch=1"
15
16 SRC_URI_append_opendreambox = " \
17            file://auto.master \
18            file://auto.network \
19            file://autofs"
20
21 SRC_URI_append_vuplus = " \
22            file://auto.master \
23            file://auto.network \
24            file://autofs"
25
26 PR = "${INC_PR}"
27
28 inherit update-rc.d
29
30 INITSCRIPT_NAME = "autofs"
31 INITSCRIPT_PARAMS = "defaults 21 19"
32
33 # FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
34 CFLAGS += "${LDFLAGS}"
35 EXTRA_OEMAKE = "STRIP=/bin/true"
36 PARALLEL_MAKE = ""
37
38 do_install_append_opendreambox () {
39         install -d ${D}${sysconfdir}/init.d
40         install ${WORKDIR}/autofs ${D}${sysconfdir}/init.d
41         install ${WORKDIR}/auto.master ${D}${sysconfdir}/auto.master
42         install ${WORKDIR}/auto.network ${D}${sysconfdir}/auto.network
43 }
44
45 do_install_append_vuplus () {
46         install -d ${D}${sysconfdir}/init.d
47         install ${WORKDIR}/autofs ${D}${sysconfdir}/init.d
48         install ${WORKDIR}/auto.master ${D}${sysconfdir}/auto.master
49         install ${WORKDIR}/auto.network ${D}${sysconfdir}/auto.network
50 }