Fix/update bb files.
authorschon <schon@dev03-server>
Mon, 14 Jun 2010 07:46:54 +0000 (16:46 +0900)
committerschon <schon@dev03-server>
Mon, 14 Jun 2010 07:46:54 +0000 (16:46 +0900)
14 files changed:
conf/distro/vuplus.conf
recipes/autofs/autofs-4.1.4/auto.hotplug [deleted file]
recipes/autofs/autofs_4.1.4.bb
recipes/avahi/avahi.inc
recipes/base-files/base-files_3.0.14.bb
recipes/gstreamer/gst-plugins-base_0.10.29.bb
recipes/gstreamer/gst-plugins.inc
recipes/hdparm/hdparm_6.6.bb
recipes/liboil/liboil_0.3.14.bb
recipes/libxmlccwrap/libxmlccwrap_0.0.12.bb
recipes/linux/linux-vusolo.bb
recipes/netbase/netbase_4.21.bb
recipes/netkit-base/netkit-base_0.17.bb
recipes/tasks/task-vuplus-enigma2.bb

index 7d801ae..f9a830d 100644 (file)
@@ -64,7 +64,7 @@ PREFERRED_VERSION_wpa-supplicant ?= "0.6.7"
 PREFERRED_VERSION_samba = "3.2.8"
 #PREFERRED_VERSION_samba = "3.0.24"
 PREFERRED_VERSION_ushare = "1.1a"
-PREFERRED_VERSION_liboil = "0.3.14"
+#PREFERRED_VERSION_liboil = "0.3.14"
 PREFERRED_VERSION_hdparm = "6.6"
 
 PREFERRED_PROVIDER_avahi = "avahi"
diff --git a/recipes/autofs/autofs-4.1.4/auto.hotplug b/recipes/autofs/autofs-4.1.4/auto.hotplug
deleted file mode 100755 (executable)
index 423e909..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-* -fstype=auto,ro :/dev/&
-#usb             -fstype=auto                    :/dev/sdb1
-#usb2             -fstype=auto                    :/dev/sdb
-#usb3             -fstype=auto                    :/dev/sdc1
-#usb4             -fstype=auto                    :/dev/sdc
-#usb             -fstype=vfat                    :/dev/sdb1
index de8925d..ae314ea 100755 (executable)
@@ -13,36 +13,26 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2
           file://no-bash.patch;patch=1 \
           file://autofs-add-hotplug.patch;patch=1"
 
-SRC_URI_vuplus = "ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
-           ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
-           ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
-           ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
-           ftp://ftp.kernel.org/pub/linux/daemons/autofs/v4/autofs-4.1.4-locking-fix-1.patch;patch=1 \
-           file://cross.patch;patch=1 \
-           file://Makefile.rules-cross.patch;patch=1 \
-                                file://install.patch;patch=1 \
-           file://autofs-add-hotplug.patch;patch=1 \
-           file://auto.master file://auto.network file://auto.hotplug \
-                                file://autofs"
-
 SRC_URI_append_opendreambox = " \
            file://auto.master \
            file://auto.network \
            file://autofs"
 
+SRC_URI_append_vuplus = " \
+           file://auto.master \
+           file://auto.network \
+           file://autofs"
+
 PR = "${INC_PR}"
 
 inherit update-rc.d
-INHERIT_append_vuplus = "pkgconfig"
 
-INITSCRIPT_PACKAGES_vuplus = "autofs"
 INITSCRIPT_NAME = "autofs"
 INITSCRIPT_PARAMS = "defaults 21 19"
 
 # FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
 CFLAGS += "${LDFLAGS}"
 EXTRA_OEMAKE = "STRIP=/bin/true"
-EXTRA_OEMAKE_vuplus="TARGET_PREFIX=${TARGET_PREFIX}"
 PARALLEL_MAKE = ""
 
 do_install_append_opendreambox () {
@@ -52,11 +42,9 @@ do_install_append_opendreambox () {
        install ${WORKDIR}/auto.network ${D}${sysconfdir}/auto.network
 }
 
-do_install_vuplus () {
-       oe_runmake 'INSTALLROOT=${D}' install
+do_install_append_vuplus () {
        install -d ${D}${sysconfdir}/init.d
        install ${WORKDIR}/autofs ${D}${sysconfdir}/init.d
        install ${WORKDIR}/auto.master ${D}${sysconfdir}/auto.master
        install ${WORKDIR}/auto.network ${D}${sysconfdir}/auto.network
-       install ${WORKDIR}/auto.hotplug ${D}${sysconfdir}/auto.hotplug
 }
index 7e9ea21..354ba1a 100755 (executable)
@@ -10,7 +10,7 @@ DEPENDS_append_vuplus = " libnss-mdns"
 
 # uclibc has no nss
 RRECOMMENDS_avahi-daemon_append_libc-glibc = " ${@base_conditional('DISTRO', 'opendreambox', 'libavahi-client zeroconf', 'libnss-mdns', d)}"
-RRECOMMENDS_avahi-daemon_append_libc-glibc_vuplus = " ${@base_conditional('DISTRO', 'vuplus', 'libavahi-client zeroconf', 'libnss-mdns', d)}"
+RRECOMMENDS_avahi-daemon_append_libc-glibc = " ${@base_conditional('DISTRO', 'vuplus', 'libavahi-client zeroconf', 'libnss-mdns', d)}"
 RDEPENDS_avahi-daemon += "sysvinit-pidof update-rc.d"
 RDEPENDS_avahi-autoipd += "update-rc.d"
 
index c3c1515..aabba45 100755 (executable)
@@ -2,7 +2,6 @@ DESCRIPTION = "Miscellaneous files for the base system."
 SECTION = "base"
 PRIORITY = "required"
 PR = "r91"
-PR_vuplus = "r58"
 
 LICENSE = "GPL"
 
@@ -27,29 +26,10 @@ SRC_URI = " \
            file://licenses/LGPL-3 \
            file://licenses/GFDL-1.2 \
            file://licenses/Artistic "
-SRC_URI_vuplus = " \
-           file://nsswitch.conf \
-           file://motd \
-           file://inputrc \
-           file://host.conf \
-           file://profile \
-           file://fstab \
-          file://filesystems \
-           file://issue.net \
-           file://issue \
-           file://usbd \
-           file://share/dot.bashrc \
-           file://share/dot.profile \
-           file://licenses/BSD \
-           file://licenses/GPL-2 \
-           file://licenses/LGPL-2 \
-           file://licenses/LGPL-2.1 \
-           file://licenses/Artistic "
 S = "${WORKDIR}"
 
 docdir_append = "/${P}"
 dirs1777 = "/tmp ${localstatedir}/volatile/lock ${localstatedir}/volatile/tmp"
-dirs1777_vuplus = "/tmp ${localstatedir}/lock ${localstatedir}/tmp"
 dirs2775 = "/home ${prefix}/src ${localstatedir}/local"
 dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
           ${sysconfdir}/skel /lib /mnt /proc /home/root /sbin \
@@ -66,19 +46,6 @@ dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
           /mnt /media /media/card /media/cf /media/net /media/ram \
           /media/union /media/realroot /media/hdd \
           /media/mmc1"
-dirs755_vuplus = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
-          ${sysconfdir}/skel /lib /mnt /proc /home/root /sbin \
-          ${prefix} ${bindir} ${docdir} /usr/games ${includedir} \
-          ${libdir} ${sbindir} ${datadir} \
-          ${datadir}/common-licenses ${datadir}/dict ${infodir} \
-          ${mandir} ${datadir}/misc ${localstatedir} \
-          ${localstatedir}/backups ${localstatedir}/cache \
-          ${localstatedir}/lib /sys ${localstatedir}/lib/misc \
-          ${localstatedir}/lock/subsys ${localstatedir}/log \
-          ${localstatedir}/run ${localstatedir}/spool \
-          /mnt /media /media/card /media/cf /media/net /media/ram \
-          /media/union /media/realroot /media/hdd \
-           /media/mmc1"
 dirs755_micro = "/dev /proc /sys ${sysconfdir}"
 dirs2775_micro = ""
 dirs1777_micro = "/tmp"
@@ -164,60 +131,6 @@ do_install () {
        install -m 0644 ${WORKDIR}/nsswitch.conf ${D}${sysconfdir}/nsswitch.conf
 }
 
-do_install_vuplus () {
-       for d in ${dirs755}; do
-               install -m 0755 -d ${D}$d
-       done
-       for d in ${dirs1777}; do
-               install -m 1777 -d ${D}$d
-       done
-       for d in ${dirs2775}; do
-               install -m 2755 -d ${D}$d
-       done
-       for d in card cf net ram; do
-               ln -sf /media/$d ${D}/mnt/$d
-       done
-
-       if [ -n "${MACHINE}" -a "${hostname}" = "openembedded" ]; then
-               echo ${MACHINE} > ${D}${sysconfdir}/hostname
-       else
-               echo ${hostname} > ${D}${sysconfdir}/hostname
-       fi
-
-        if [ -n "${DISTRO_NAME}" ]; then
-               echo -n "${DISTRO_NAME} " > ${D}${sysconfdir}/issue
-               echo -n "${DISTRO_NAME} " > ${D}${sysconfdir}/issue.net
-               if [ -n "${DISTRO_VERSION}" ]; then
-                       echo -n "${DISTRO_VERSION} " >> ${D}${sysconfdir}/issue
-                       echo -n "${DISTRO_VERSION} " >> ${D}${sysconfdir}/issue.net
-               fi
-               echo "\n \l" >> ${D}${sysconfdir}/issue
-               echo >> ${D}${sysconfdir}/issue
-               echo "%h"    >> ${D}${sysconfdir}/issue.net
-               echo >> ${D}${sysconfdir}/issue.net
-       else
-              install -m 0644 ${WORKDIR}/issue ${D}${sysconfdir}/issue
-              install -m 0644 ${WORKDIR}/issue.net ${D}${sysconfdir}/issue.net
-       fi
-
-       install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab
-       install -m 0644 ${WORKDIR}/filesystems ${D}${sysconfdir}/filesystems
-       install -m 0644 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd
-       install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/profile
-       install -m 0755 ${WORKDIR}/share/dot.profile ${D}${sysconfdir}/skel/.profile
-       install -m 0755 ${WORKDIR}/share/dot.bashrc ${D}${sysconfdir}/skel/.bashrc
-       install -m 0644 ${WORKDIR}/inputrc ${D}${sysconfdir}/inputrc
-       install -m 0644 ${WORKDIR}/nsswitch.conf ${D}${sysconfdir}/nsswitch.conf
-       install -m 0644 ${WORKDIR}/host.conf ${D}${sysconfdir}/host.conf
-       install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd
-
-       for license in BSD GPL-2 LGPL-2 LGPL-2.1 Artistic; do
-               install -m 0644 ${WORKDIR}/licenses/$license ${D}${datadir}/common-licenses/
-       done
-
-       ln -sf /proc/mounts ${D}${sysconfdir}/mtab
-}
-
 do_install_append_mnci () {
        rmdir ${D}/tmp
        ln -s var/tmp ${D}/tmp
@@ -259,8 +172,6 @@ do_install_append_vuplus() {
 
 PACKAGES = "${PN}-dbg ${PN}-doc ${PN}"
 FILES_${PN} = "/*"
-PACKAGES_vuplus = "${PN}-doc ${PN}"
-FILES_${PN}_vuplus = "/"
 FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"
 
 # M&N specific packaging
index 3526661..1b9febe 100644 (file)
@@ -1,6 +1,9 @@
 require gst-plugins.inc
 
 SRC_URI_append_opendreambox = " file://samihack.patch;patch=1 \
+file://playbin2-Set-subtitle-encoding-on-the-decodebins-a.patch;patch=1 \
+file://playbin2-If-a-text-sink-is-provided-let-subtitle-p.patch;patch=1 "
+
 SRC_URI_append_vuplus = " file://samihack.patch;patch=1 \
 file://playbin2-Set-subtitle-encoding-on-the-decodebins-a.patch;patch=1 \
 file://playbin2-If-a-text-sink-is-provided-let-subtitle-p.patch;patch=1 "
index 2c7483d..9d70c45 100755 (executable)
@@ -14,8 +14,7 @@ SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2"
 EXTRA_OECONF = "--enable-introspection=no --disable-aalib --disable-shout2 --disable-sdl --disable-cdaudio --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} "
 EXTRA_OECONF_append_shr = " --disable-dvdnav "
 EXTRA_OECONF_opendreambox = "--disable-x --disable-aalib --disable-esd --disable-shout2 --disable-sdl --with-check=no --enable-neon "
-EXTRA_OECONF_bm750 = "--disable-x --disable-aalib --disable-esd --disable-shout2 --disable-sdl --with-check=no --enable-neon "
-EXTRA_OECONF_vusolo = "--disable-x --disable-aalib --disable-esd --disable-shout2 --disable-sdl --with-check=no --enable-neon "
+EXTRA_OECONF_vuplus = "--disable-x --disable-aalib --disable-esd --disable-shout2 --disable-sdl --with-check=no --enable-neon "
 
 acpaths = "-I ${S}/common/m4 -I ${S}/m4"
 
index 3e71fb0..af87b0f 100755 (executable)
@@ -13,7 +13,3 @@ do_install () {
        oe_runmake 'DESTDIR=${D}' install
 }
 
-do_install_vuplus () {
-       install -d ${D}/sbin/
-       install -m 0755 ${S}/hdparm ${D}/sbin/hdparm
-}
index ef038ef..ebbe6cf 100755 (executable)
@@ -1,23 +1,15 @@
 DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
 HOMEPAGE = "http://liboil.freedesktop.org/"
 LICENSE = "various"
-PR_vuplus = "r0"
 
 # The configure script seems to have bogus checks, so let's not make it the default
 DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_vuplus = ""
 
 DEPENDS = "glib-2.0"
-DEPENDS_vuplus = ""
 
 SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz \
           "
 
-SRC_URI_append_vuplus = " \
-       file://no_ppc_altivec.diff;patch=1;pnum=1 \
-       file://no_ppc_fpu.diff;patch=1;pnum=1 \
-       file://fix_ppc_build_with_old_kernel.diff;patch=1;pnum=1"
-
 inherit autotools pkgconfig
 
 do_stage() {
index bc97ba8..a0e8b43 100755 (executable)
@@ -18,7 +18,6 @@ FILES_${PN}-dev = " \
        /usr/include/*.h \
        /usr/include/xmlccwrap/*.h \
        /usr/lib/libxmlccwrap.la"
-FILES_${PN}-dev_vuplus = "/usr/include/*.h"
 
 do_stage () {
        install -d ${STAGING_INCDIR}/xmlccwrap
index e87e656..ffbcc4f 100644 (file)
@@ -16,6 +16,7 @@ SRC_URI += "file://stblinux-2.6.18.makefile.patch;patch=1 \
 SRC_URI += "file://linux-vusolo_nand4.patch;patch=1;pnum=0 \
        file://linux-vusolo_info.patch;patch=1;pnum=0 \
        file://linux-vusolo_resource.patch;patch=1;pnum=0 \
+       file://linux_bm750_arch_makefile.patch;patch=1;pnum=0 \
        file://linux-vusolo_kojbect.patch;patch=1;pnum=0 \
        file://linux-vusolo_dvb-core_fe.patch;patch=1;pnum=0 \
        file://linux-vusolo_romblock.patch;patch=1;pnum=0 \
index 52562c4..a4903df 100755 (executable)
@@ -3,12 +3,10 @@ infrastructure for basic TCP/IP based networking."
 SECTION = "base"
 LICENSE = "GPL"
 PR = "r40"
-PR_vuplus = "r14"
 
 inherit update-rc.d
 
 SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
-SRC_URI_OVERRIDES_PACKAGE_ARCH_vuplus = ""
 
 INITSCRIPT_NAME = "networking"
 INITSCRIPT_PARAMS = "start 40 S . stop 40 0 6 1 ."
@@ -29,11 +27,6 @@ SRC_URI = "\
   file://if-down.d \
   file://if-post-down.d \
 "
-SRC_URI_vuplus = "${DEBIAN_MIRROR}/main/n/netbase/netbase_${PV}.tar.gz \
-           file://options \
-           file://init \
-           file://hosts \
-           file://interfaces"
 
 do_install () {
        install -d ${D}${sysconfdir}/init.d
@@ -65,26 +58,7 @@ do_install () {
        install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
 }
 
-do_install_vuplus () {
-       install -d ${D}${sysconfdir}/init.d \
-                  ${D}${sbindir} \
-                  ${D}${mandir}/man8 \
-                  ${D}${sysconfdir}/network/if-pre-up.d \
-                  ${D}${sysconfdir}/network/if-up.d \
-                  ${D}${sysconfdir}/network/if-down.d \
-                  ${D}${sysconfdir}/network/if-post-down.d
-       install -m 0644 ${WORKDIR}/options ${D}${sysconfdir}/network/options
-       install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
-       install -m 0644 ${WORKDIR}/hosts ${D}${sysconfdir}/hosts
-       install -m 0644 etc-rpc ${D}${sysconfdir}/rpc
-       install -m 0644 etc-protocols ${D}${sysconfdir}/protocols
-       install -m 0644 etc-services ${D}${sysconfdir}/services
-       install -m 0755 update-inetd ${D}${sbindir}/
-       install -m 0644 update-inetd.8 ${D}${mandir}/man8/
-       install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
-}
 
 CONFFILES_${PN} = "${sysconfdir}/network/options ${sysconfdir}/hosts \
                    ${sysconfdir}/network/interfaces ${sysconfdir}/rpc \
                    ${sysconfdir}/protocols ${sysconfdir}/services"
-CONFFILES_${PN}_vuplus = "${sysconfdir}/network/options ${sysconfdir}/hosts ${sysconfdir}/network/interfaces"
index 23160d0..f58ad4d 100755 (executable)
@@ -2,7 +2,6 @@ SECTION = "base"
 DESCRIPTION = "netkit-base includes the inetd daemon."
 LICENSE = "BSD"
 PR = "r1"
-PR_vuplus = "r3"
 
 SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-base-${PV}.tar.gz \
            file://configure.patch;patch=1 \
index 196d5aa..31e1e89 100644 (file)
@@ -24,10 +24,6 @@ RDEPENDS_task-vuplus-enigma2 = "\
   enigma2 \
   enigma2-defaultservices \
   enigma2-plugin-extensions-mediascanner \
-  enigma2-plugin-systemplugins-hotplug \
-  enigma2-plugin-systemplugins-networkwizard \
-#  enigma2-plugin-systemplugins-softwaremanager \
-  enigma2-plugin-systemplugins-videotune \
   enigma2-plugin-systemplugins-factorytest \
   enigma2-streamproxy \
   tuxbox-tuxtxt-32bpp \