Remove WARNING messages.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-plugins.bb
index e50eccb..2b67a00 100755 (executable)
@@ -11,7 +11,7 @@ SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
 SRCDATE="20110215"
 BRANCH="master"
 PV = "experimental-git${SRCDATE}"
-PR = "r10"
+PR = "r12"
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
@@ -22,20 +22,22 @@ EXTRA_OECONF = " \
         HOST_SYS=${HOST_SYS} \
         STAGING_INCDIR=${STAGING_INCDIR} \
         STAGING_LIBDIR=${STAGING_LIBDIR} \
+       --with-gstversion=1.0 \
 "
 
 SRC_URI_append_vuplus = " \
-       file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
-       file://enigma2_plugins_20121113.patch;patch=1;pnum=1 \
-       file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
-       file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
-       file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
-       file://enigma2_plugins_fancontrol2.patch;patch=1;pnum=1 \
-       file://enigma2_plugins_gst_plugins_pkgname.patch;patch=1;pnum=1 \
+       file://enigma2_plugins_mytube_tpm.patch \
+       file://enigma2_plugins_20121113.patch \
+       file://enigma2_plugins_webinterface_tpm.patch \
+       file://enigma2_plugins_ac3lipsync_dolby.patch \
+       file://enigma2_plugins_autoresolution_fix.patch \
+       file://enigma2_plugins_fancontrol2.patch \
+       file://enigma2_plugins_gst10_support.patch \
+       file://enigma2_plugins_fix_depends_pkgname.patch \
        file://dreamboxweb.png \
        file://dreamboxwebtv.png \
        file://favicon.ico \
-       file://Makefile.am
+       file://Makefile.am \
 "
 
 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
@@ -43,12 +45,20 @@ FILES_${PN}-meta = "${datadir}/meta"
 PACKAGES += "${PN}-meta"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-inherit autotools
+inherit autotools-brokensep pythonnative pkgconfig
 
 S = "${WORKDIR}/git"
 
-DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
-DEPENDS += "enigma2"
+DEPENDS = " \
+       enigma2 \
+       python-pyopenssl \
+       python-gdata \
+       streamripper \
+       python-mutagen \
+       python-daap \
+       enigma2-plugin-extensions-openwebif \
+       gstreamer1.0-plugins-bad \
+       "
 
 def modify_po():
     import os
@@ -83,7 +93,7 @@ def changeword2(file):
     os.system(cmd1)
 
 do_unpack_append(){
-       modify_po()
+    modify_po()
 }
 
 do_configure_prepend_vuplus() {
@@ -94,6 +104,7 @@ do_install_append_vuplus() {
        install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
        install -m 0644 ${WORKDIR}/dreamboxwebtv.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/tpl/default/streaminterface/img
        install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
+       rm -r ${D}/media
 }
 
 python populate_packages_prepend() {
@@ -114,7 +125,14 @@ python populate_packages_prepend() {
             if name == 'Description':
                 d.setVar('DESCRIPTION_' + package, value)
             elif name == 'Depends':
-                d.setVar('RDEPENDS_' + package, ' '.join(value.split(', ')))
+                rdepends = []
+                for depend in value.split(','):
+                    depend = depend.strip()
+                    if depend.startswith('enigma2') and not depend.startswith('enigma2-'):
+                        rdepends.append('enigma2')
+                    else:
+                        rdepends.append(depend)
+                d.setVar('RDEPENDS_' + package, ' '.join(rdepends))
             elif name == 'Replaces':
                 d.setVar('RREPLACES_' + package, ' '.join(value.split(', ')))
             elif name == 'Conflicts':