[openwebif] support file transcoding.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-filestreamproxy.bb
diff --git a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-filestreamproxy.bb b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-filestreamproxy.bb
new file mode 100644 (file)
index 0000000..ed4d17f
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "file transcoding util."
+PRIORITY = "required"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+PR = "r0"
+SRCREV="4601bc13bc6f08e124d60f7c004ff2e1cacdfc31"
+
+SRC_URI = "git://code.vuplus.com/git/filestreamproxy.git;protocol=git;branch=master;tag=${SRCREV}"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+
+do_install() {
+       install -d ${D}/usr/bin
+       install -m 0755 ${S}/src/filestreamproxy ${D}/usr/bin
+}
+
+FILES_${PN} = "${bindir}/filestreamproxy"
+
+PACKAGE_ARCH := "${MACHINE_ARCH}"
+PACKAGES = "${PN}"
+