fixed login security hole.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-extended / shadow / shadow_4.1.4.3.bbappend
diff --git a/meta-openvuplus/recipes-extended/shadow/shadow_4.1.4.3.bbappend b/meta-openvuplus/recipes-extended/shadow/shadow_4.1.4.3.bbappend
new file mode 100644 (file)
index 0000000..d8d1769
--- /dev/null
@@ -0,0 +1,25 @@
+PR .= "vuplus0"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
+
+pkg_postinst_${PN} () {
+       for i in chpasswd chfn newgrp chsh groups vipw vigr ; do
+               update-alternatives --install ${sbindir}/$i $i $i.${PN} 200
+       done 
+
+        if [ "x$D" != "x" ]; then
+               rootarg="--root=$D"
+        else
+               rootarg=""
+        fi
+
+        pwconv $rootarg
+        grpconv $rootarg
+}
+
+pkg_prerm_${PN} () {
+        for i in chpasswd chfn newgrp chsh groups vipw vigr ; do
+                update-alternatives --remove $i $i.${PN}
+        done
+}
+