Use python-twisted from meta-openembedded. (version update : 12.0.0 -> 13.2.0)
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-devtools / python / python-twisted_13.2.%.bbappend
diff --git a/meta-openvuplus/recipes-devtools/python/python-twisted_13.2.%.bbappend b/meta-openvuplus/recipes-devtools/python/python-twisted_13.2.%.bbappend
new file mode 100644 (file)
index 0000000..f9b0ae8
--- /dev/null
@@ -0,0 +1,29 @@
+PR = "r2"
+
+inherit setuptools
+
+PACKAGES =+ "\
+       ${PN}-src \
+       ${PN}-bin \
+"
+
+RDEPENDS_{PN} += "${PN}-bin"
+RDEPENDS_{PN}-src = "${PN}"
+FILES_${PN}-src = " \
+       ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
+       ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
+       ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
+       "
+
+RDEPENDS_${PN}-test = "${PN}"
+RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-lore = "${PN}-core"
+RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-names = "${PN}-core"
+RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-words += "${PN}-core"
+RDEPENDS_${PN}-flow += "${PN}-core"
+RDEPENDS_${PN}-pair += "${PN}-core"
+RDEPENDS_${PN}-dbg = "${PN}"