do sync after umountfs
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-core / initscripts / initscripts_1.0.bbappend
index 46b30e6..168eeeb 100644 (file)
@@ -1,12 +1,12 @@
-PR .= "-vuplus4"
+PR .= "-vuplus9"
 
-BOOTUP = "bootup_3.1" 
+FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
 
 SRC_URI_append = " \
        file://turnoff_power \
        file://hotplug_br \
        file://make_mac_sector \
-       file://${BOOTUP} \
+       file://mountrun.sh \
 "
 
 do_install_append() {
@@ -16,8 +16,9 @@ do_install_append() {
        install -m 0755 ${WORKDIR}/turnoff_power     ${D}/usr/bin
        install -m 0755 ${WORKDIR}/hotplug_br        ${D}/usr/bin
        install -m 0755 ${WORKDIR}/make_mac_sector   ${D}/usr/bin
-       install -m 0755 ${WORKDIR}/${BOOTUP}         ${D}${sysconfdir}/init.d/bootup
-       ln      -sf     ../init.d/bootup             ${D}${sysconfdir}/rcS.d/S05bootup
+
+       install -m 0755 ${WORKDIR}/mountrun.sh ${D}${sysconfdir}/init.d
+        ln -s ../init.d/mountrun.sh ${D}${sysconfdir}/rcS.d/S02mountrun.sh
 
        # rename umountnfs script because it should run before network is disabled
         mv ${D}${sysconfdir}/rc0.d/S31umountnfs.sh ${D}${sysconfdir}/rc0.d/K31umountnfs.sh || /bin/true