Merge branch 'opendreambox' of /home/tmbinc/openembedded.git/ into opendreambox
authorAndreas Oberritter <obi@saftware.de>
Wed, 22 Oct 2008 15:07:03 +0000 (17:07 +0200)
committerAndreas Oberritter <obi@saftware.de>
Wed, 22 Oct 2008 15:07:03 +0000 (17:07 +0200)
1  2 
packages/linux/linux-dm8000.bb

@@@ -3,10 -3,10 +3,10 @@@ LICENSE = "GPL
  PN = "linux-dm8000"
  KV = "2.6.12"
  PV = "2.6.12"
- PR = "r5"
+ PR = "r6"
  
  # note, the rX in the filename is *NOT* the packet revision - it's the patch revision.
 -SRC_URI += "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
 +SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
        file://dm8000_defconfig \
        http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-brcm-5.1.patch.bz2;patch=1;pnum=1 \
        http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-update_dvbapi-r1.patch.bz2;patch=1;pnum=1 \
@@@ -28,7 -28,8 +28,8 @@@
        file://linuxmips-2.6.12-fix-futex.patch;patch=1;pnum=1 \
        file://linuxmips-2.6.12-gcc4-compile-fix.patch;patch=1;pnum=1 \
        file://linuxmips-2.6.12-gdb-fix.patch;patch=1;pnum=1 \
-       file://linux-2.6.12-brcm-fix-minipci.patch;patch=1;pnum=1"
+       file://linux-2.6.12-brcm-fix-minipci.patch;patch=1;pnum=1 \
+       http://trappist.elis.ugent.be/~mronsse/cdfs/download/cdfs-2.6.12.tar.bz2"
  
  S = "${WORKDIR}/stblinux-2.6.12"
  
@@@ -52,6 -53,10 +53,10 @@@ addtask munge before do_patch after do_
  
  do_configure_prepend() {
        oe_machinstall -m 0644 ${WORKDIR}/dm8000_defconfig ${S}/.config
+       if [ -d ${WORKDIR}/cdfs-${PV} ]; then
+               mv ${WORKDIR}/cdfs-${PV} ${S}/fs/cdfs
+               cd ${S} & patch -p0 < ${S}/fs/cdfs/patch.cdfs
+       fi;
        oe_runmake oldconfig
  }