linux-dm8000: use $KERNELORG_MIRROR to match checksums.ini
[vuplus_openembedded] / packages / linux / linux-dm8000.bb
1 DESCRIPTION = "Linux kernel for Dreambox DM8000"
2 LICENSE = "GPL"
3 PN = "linux-dm8000"
4 KV = "2.6.12"
5 PV = "2.6.12"
6 PR = "r5"
7
8 # note, the rX in the filename is *NOT* the packet revision - it's the patch revision.
9 SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2 \
10         file://dm8000_defconfig \
11         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-brcm-5.1.patch.bz2;patch=1;pnum=1 \
12         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-update_dvbapi-r1.patch.bz2;patch=1;pnum=1 \
13         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dvb-multipid-r4.patch.bz2;patch=1;pnum=1 \
14         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dvb-core-fix-several-locking-problems.patch.bz2;patch=1;pnum=1 \
15         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-dvbapi-pilot-rolloff-extension-r0.patch.bz2;patch=1;pnum=1 \
16         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-update-wireless.patch.bz2;patch=1;pnum=1 \
17         http://sources.dreamboxupdate.com/download/kernel-patches/linux-2.6.12-add-ioprio.patch.bz2;patch=1;pnum=1 \
18         file://linux-2.6.12-dvbapi-support-more-demux.patch;patch=1;pnum=1 \
19         file://linux-2.6.12-dream-misc.patch;patch=1;pnum=1 \
20         file://linux-2.6.12-dm8000-nand.patch;patch=1;pnum=1 \
21         file://linux-2.6.12-dream-temp.patch;patch=1;pnum=1 \
22         file://linux-2.6.12-brcm-mtd-blkdevfs-fix.diff;patch=1;pnum=1 \
23         file://linux-2.6.12-brcm-fix-usb-for-revb0.diff;patch=1;pnum=1 \
24         file://linux-2.6.12-set-custom-extraversion.patch;patch=1;pnum=1 \
25         file://linux-2.6.12-fixup-prom-args.patch;patch=1;pnum=1 \
26         file://linux-2.6.12-7400AB-enable-llsc.patch;patch=1;pnum=1 \
27         file://linuxmips-2.6.12-fix-fadvise.patch;patch=1;pnum=1 \
28         file://linuxmips-2.6.12-fix-futex.patch;patch=1;pnum=1 \
29         file://linuxmips-2.6.12-gcc4-compile-fix.patch;patch=1;pnum=1 \
30         file://linuxmips-2.6.12-gdb-fix.patch;patch=1;pnum=1 \
31         file://linux-2.6.12-brcm-fix-minipci.patch;patch=1;pnum=1"
32
33 S = "${WORKDIR}/stblinux-2.6.12"
34
35 inherit kernel
36
37 FILES_kernel-image = "/boot/vmlinux.gz /boot/autoexec.bat"
38
39 export OS = "Linux"
40 KERNEL_IMAGETYPE = "vmlinux"
41 KERNEL_OUTPUT = "vmlinux"
42 KERNEL_OBJECT_SUFFIX = "ko"
43
44 do_munge() {
45         mv ${WORKDIR}/linux-2.6.12 ${WORKDIR}/stblinux-2.6.12
46         if [ -d ${S}/drivers/sound ]; then
47                 rm -R ${S}/drivers/sound;
48         fi;
49 }
50
51 addtask munge before do_patch after do_unpack
52
53 do_configure_prepend() {
54         oe_machinstall -m 0644 ${WORKDIR}/dm8000_defconfig ${S}/.config
55         oe_runmake oldconfig
56 }
57
58 do_install_append () {
59         install -d ${D}/boot
60         install -m 0755 vmlinux ${D}/boot/vmlinux
61         echo "/flash/bootlogo.elf" > ${D}/boot/autoexec.bat
62         gzip ${D}/boot/vmlinux
63         echo "/flash/vmlinux.gz" >> ${D}/boot/autoexec.bat
64 }
65
66 pkg_preinst_kernel-image () {
67         [ -d /proc/stb ] && mount -o rw,remount /boot
68 }
69
70 pkg_postinst_kernel-image () {
71         [ -d /proc/stb ] && mount -o ro,remount /boot
72 }
73
74 pkg_prerm_kernel-image () {
75         [ -d /proc/stb ] && mount -o rw,remount /boot
76 }
77
78 pkg_postrm_kernel-image () {
79         [ -d /proc/stb ] && mount -o ro,remount /boot
80 }