opera hbbtv.
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
index abf5f8b..70b4aee 100644 (file)
@@ -3,21 +3,22 @@ MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        dreambox-dvbincludes freetype libdvbsi++ python swig-native \
        libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
-       gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi"
+       gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data \
+       hostap-daemon bridge-utils djmount minidlna mpfr gmp tslib opera-hbbtv"
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
-       python-pickle gst-plugin-app \
+       python-pickle gst-plugin-app gst-plugin-fragmented \
        gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
        gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
        gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
        gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
        gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
-       gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect \
+       gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect gst-plugin-flv \
        glibc-gconv-iso8859-15 ethtool"
 
 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
-GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-qtdemux gst-plugin-vorbis gst-plugin-audioparsersbad"
+GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-isomp4 gst-plugin-vorbis gst-plugin-audioparsers"
 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
 
@@ -59,12 +60,23 @@ DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect t
 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
+DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
+RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
+RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
+DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
+RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
+RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usbmodeswitch usbmodeswitch-data wvdial wvstreams libwvutils4.6 libwvstreams-extras libuniconf4.6"
+RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
+RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugin-rtmp "
+RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount fuse-utils libfuse2 libupnp3 kernel-module-fuse "
+RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna libexif12 libavformat52 libavutil50 libavcodec52 libgsm1 libmp3lame0 libschroedinger-1.0-0 libtheora0 liboil"
+RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 directfb libgmp3 libmpfr1 opera-hbbtv"
 
 PN = "enigma2"
-PR = "r0"
+PR = "r40"
 
-SRCDATE = "20110217"
+SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
 #SRCDATE is NOT used by git to checkout a specific revision
 #but we need it to build a ipk package version
@@ -100,18 +112,18 @@ PV_vuplus = "experimental-git${SRCDATE}"
 SRCREV_vuplus = ""
 ####################################################
 
-SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
-SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
+#SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
+#SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
 
 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
 
 
-SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git.5.9;protocol=http;branch=${BRANCH};tag=${SRCREV} \
-          file://enigma2_vuplus_vfd.patch;patch=1;pnum=1 \
+SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
           file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
+           file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
            file://MyriadPro-Regular.otf \
            file://MyriadPro-Semibold.otf \
            file://MyriadPro-SemiboldIt.otf \
@@ -120,49 +132,18 @@ SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git.5.9;protocol=http;bran
            file://number_key \
            "
 
-SRC_URI_vusolo = "git://archive.vuplus.com/git/enigma2.git.5.9;protocol=http;branch=${BRANCH};tag=${SRCREV} \
-           file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
-          file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_misc.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
-           file://MyriadPro-Regular.otf \
-           file://MyriadPro-Semibold.otf \
-           file://MyriadPro-SemiboldIt.otf \
-           file://750S \
-           file://Vu_HD \
-           file://number_key \
-           "
+SRC_URI_append_bm750 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
+SRC_URI_append_vuuno = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
 
+SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
 
+SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
 
-SRC_URI_vuuno = "git://archive.vuplus.com/git/enigma2.git.5.9;protocol=http;branch=${BRANCH};tag=${SRCREV} \
-          file://enigma2_vuplus_vfd.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
-          file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
-           file://MyriadPro-Regular.otf \
-           file://MyriadPro-Semibold.otf \
-           file://MyriadPro-SemiboldIt.otf \
-           file://750S \
-           file://Vu_HD \
-           file://number_key \
-           "
-
-SRC_URI_vuultimo = "git://archive.vuplus.com/git/enigma2.git.5.9;protocol=http;branch=${BRANCH};tag=${SRCREV} \
-          file://enigma2_vuplus_vfd.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
-          file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
-           file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
-           file://MyriadPro-Regular.otf \
-           file://MyriadPro-Semibold.otf \
-           file://MyriadPro-SemiboldIt.otf \
-           file://750S \
-           file://Vu_HD \
-           file://number_key \
-           "
+SRC_URI_append_vuultimo = " \
+           file://analog.ttf \
+           file://skin_user.xml \
+           file://vfd_icons \
+"
 
 def change_po():
         import os
@@ -219,12 +200,23 @@ do_compile_prepend_vuplus() {
 }
 
 EXTRA_OECONF = " \
+       ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
+       ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
+       ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
+       ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
         BUILD_SYS=${BUILD_SYS} \
         HOST_SYS=${HOST_SYS} \
         STAGING_INCDIR=${STAGING_INCDIR} \
         STAGING_LIBDIR=${STAGING_LIBDIR} \
 "
 
+do_install_append_vuultimo() {
+        install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
+        install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
+        install -d ${D}/usr/share/enigma2/vfd_icons/
+        install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
+}
+
 python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)