[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / zaurusd / zaurusd_svn.bb
1 DESCRIPTION = "Daemon to handle device specific features."
2 SECTION = "base"
3 LICENSE = "GPL"
4 DEPENDS = "tslib"
5 RDEPENDS = "procps"
6 PV = "0.0+svn${SRCDATE}"
7 PR = "r22"
8
9 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
10            file://zaurus-hinge.in \
11            file://add-poodle.patch;patch=1 \
12            file://alsa-cxx00-default.state.patch;patch=1 \
13            file://alsa-6000x-default.state.patch;patch=1 \
14            file://disable-alsa-handling.patch;patch=1 \
15            file://avoid-rotated-server.patch;patch=1 \
16            file://zaurus-hinge.matchbox-portrait \
17            file://zaurus-hinge.matchbox-landscape \
18            file://zaurus-hinge.bl-on \
19            file://zaurus-hinge.bl-off \
20            file://01-check-toggle-landscape \
21            file://01-check-toggle-portait \
22        file://use-ts-symlink-instead-of-hardcoding.diff;patch=1 "
23
24
25 S = "${WORKDIR}/${PN}"
26
27 PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29 do_configure_prepend () {
30         cp ${WORKDIR}/zaurus-hinge.in ${S}/scripts
31 }
32
33 do_install_append() {
34         install -d "${D}/etc/zaurusd/hinge-landscape.d"
35         install -d "${D}/etc/zaurusd/hinge-portrait.d"
36         install -d "${D}/etc/zaurusd/hinge-close.d"
37         install -d ${D}/etc/apm/resume.d
38
39         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/apm/resume.d/00-backlight-on"
40         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-landscape.d/00-backlight-on"
41         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-portrait.d/00-backlight-on"
42         install -m 0755 "${WORKDIR}/zaurus-hinge.bl-off" "${D}/etc/zaurusd/hinge-close.d/00-backlight-off"
43
44         install -m 0755 "${WORKDIR}/01-check-toggle-landscape" "${D}/etc/zaurusd/hinge-landscape.d/01-check-toggle"
45         install -m 0755 "${WORKDIR}/01-check-toggle-portait" "${D}/etc/zaurusd/hinge-portrait.d/01-check-toggle"
46
47         install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-landscape" "${D}/etc/zaurusd/hinge-landscape.d/20-matchbox-landscape"
48         install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-portrait" "${D}/etc/zaurusd/hinge-portrait.d/20-matchbox-portrait"
49 }
50
51 inherit autotools pkgconfig update-rc.d
52
53 INITSCRIPT_NAME = "zaurusd"
54 INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."