surpport seeking the recorded video
[vuplus_openembedded] / recipes / xorg-xserver / xserver-kdrive_1.4.99.901.bb
1 require xserver-kdrive-common.inc
2
3 DEPENDS += "hal libxkbfile libxcalibrate pixman"
4 RDEPENDS += "hal"
5
6 DEFAULT_PREFERENCE = "-99" 
7
8 PE = "1"
9 PR = "${INC_PR}.0"
10
11 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
12         ${KDRIVE_COMMON_PATCHES} \
13         file://enable-epson.patch;patch=1 \
14         file://fix_default_mode.patch;patch=1 \
15 #       file://hide-cursor-and-ppm-root.patch;patch=1 \
16 #       file://xcalibrate_coords.patch;patch=1 \
17         file://w100.patch;patch=1 \
18         file://w100-autofoo.patch;patch=1 \
19         file://w100-fix-offscreen-bmp.patch;patch=1 \
20         file://w100-new-input-world-order.patch;patch=1 \
21         file://linux-keyboard-mediumraw.patch;patch=1 \
22         file://xcalibrate-new-input-world-order.patch;patch=1 \
23         file://tslib-default-device.patch;patch=1 \
24 #       file://fbdev-evdev.patch;patch=1 \
25         file://keyboard-resume-workaround.patch;patch=1 \
26         file://xorg-avr32-support.diff;patch=1 \
27 #       file://pkgconfig_fix.patch;patch=1 \
28         file://no_xkb.patch;patch=1;pnum=0 \
29         "
30
31 S = "${WORKDIR}/xorg-server-${PV}"
32
33 W100_OECONF = "--disable-w100"
34 #W100_OECONF_arm = "--enable-w100"
35
36 EXTRA_OECONF += "--enable-builtin-fonts \
37                  --disable-dri2 \
38                 "