surpport seeking the recorded video
[vuplus_openembedded] / recipes / xorg-xserver / xserver-kdrive_1.4.2.bb
1 require xserver-kdrive-common.inc
2
3 DEPENDS += "hal libxkbfile libxcalibrate pixman"
4 RDEPENDS += "hal"
5
6 PE = "1"
7 PR = "${INC_PR}.0"
8
9 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
10         ${KDRIVE_COMMON_PATCHES} \
11         file://enable-epson.patch;patch=1 \
12         file://fix_default_mode.patch;patch=1 \
13         file://enable-xcalibrate.patch;patch=1 \
14         file://hide-cursor-and-ppm-root.patch;patch=1 \
15         file://xcalibrate_coords.patch;patch=1 \
16         file://w100.patch;patch=1 \
17         file://w100-autofoo.patch;patch=1 \
18         file://w100-fix-offscreen-bmp.patch;patch=1 \
19         file://w100-new-input-world-order.patch;patch=1 \
20         file://linux-keyboard-mediumraw.patch;patch=1 \
21         file://xcalibrate-new-input-world-order.patch;patch=1 \
22         file://tslib-default-device.patch;patch=1 \
23         file://fbdev-evdev.patch;patch=1 \
24         file://keyboard-resume-workaround.patch;patch=1 \
25         file://xorg-avr32-support.diff;patch=1 \
26         file://pkgconfig_fix.patch;patch=1 \
27         file://no_xkb.patch;patch=1;pnum=0 \
28         "
29
30 S = "${WORKDIR}/xorg-server-${PV}"
31
32 W100_OECONF = "--disable-w100"
33 W100_OECONF_arm = "--enable-w100"
34
35 EXTRA_OECONF += "--enable-builtin-fonts"