surpport seeking the recorded video
[vuplus_openembedded] / recipes / xorg-xserver / xserver-kdrive_1.3.0.0.bb
1 require xserver-kdrive-common.inc
2
3 DEPENDS += "libxkbfile libxcalibrate"
4
5 PE = "1"
6 PR = "${INC_PR}.0"
7
8 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
9         ${KDRIVE_COMMON_PATCHES} \
10         file://enable-epson.patch;patch=1 \
11         file://enable-builtin-fonts.patch;patch=1 \
12         file://kdrive-evdev.patch;patch=1  \
13         file://kdrive-use-evdev.patch;patch=1  \
14         file://disable-xf86-dga-xorgcfg.patch;patch=1 \
15         file://fix_default_mode.patch;patch=1 \
16         file://enable-xcalibrate.patch;patch=1 \
17         file://hide-cursor-and-ppm-root.patch;patch=1 \
18         file://xcalibrate_coords.patch;patch=1 \
19         file://w100.patch;patch=1 \
20         file://w100-autofoo.patch;patch=1 \
21         file://w100-fix-offscreen-bmp.patch;patch=1 \
22         file://kdrive-1.3-18bpp.patch;patch=1 \
23         file://linux-keyboard-mediumraw.patch;patch=1 \
24         file://gumstix-kmode.patch;patch=1 \
25         file://fix-picturestr-include-order.patch;patch=1 \
26         file://autotools.patch;patch=1 \
27         file://report-correct-randr12.patch;patch=1 \
28 "
29
30 SRC_URI_append_avr32 = " \
31         file://xorg-avr32-support.diff;patch=1 \
32 "
33
34 SRC_URI_append_tosa = "file://tosa-fbdev.patch;patch=1"
35 PACKAGE_ARCH_xserver-kdrive-fbdev_tosa = "${MACHINE_ARCH}"
36
37 S = "${WORKDIR}/xorg-server-${PV}"
38
39 W100_OECONF = "--disable-w100"
40 W100_OECONF_arm = "--enable-w100"
41