surpport seeking the recorded video
[vuplus_openembedded] / recipes / xfce-base / xfce4-panel_4.4.2.bb
1 # xfce4-panel OE build file
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see COPYING.MIT)
4
5 DESCRIPTION = "XFCE4 Panel"
6 SECTION = "x11"
7 DEPENDS = "startup-notification virtual/libx11 libxfcegui4 libxfce4mcs xfce-mcs-manager libxml2"
8
9 inherit pkgconfig xfce
10
11 EXTRA_OECONF += " --enable-startup-notification"
12
13
14 do_stage() {
15 autotools_stage_all
16 }
17
18 do_install() {
19     oe_runmake DESTDIR=${D} install
20 }
21
22 python populate_packages_prepend() {
23         plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
24         plugin_name = bb.data.expand('${PN}-plugin-%s', d)
25         do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
26                           '${PN} plugin for %s', extra_depends='', prepend=True,
27                           aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
28                                              '${sysconfdir}/xdg/xfce/panel/%s-*',
29                                              '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
30                                              '${bindir}/*%s*'])
31 }
32
33 PACKAGES += "${PN}-mcs-plugins"
34 PACKAGES_DYNAMIC = "${PN}-plugin-*"
35
36 FILES_${PN}-mcs-plugins += "${libdir}/xfce4/mcs-plugins/"
37 FILES_${PN}-dbg += "${libdir}/xfce4/mcs-plugins/.debug"