surpport seeking the recorded video
[vuplus_openembedded] / recipes / xfce-base / libxfce4util_4.6.1.bb
1 # libxfce4util OE build file
2
3 DESCRIPTION = "Basic utility library for Xfce4"
4 SECTION = "x11/libs"
5 LICENSE = "GPL"
6 DEPENDS = "glib-2.0 xfce4-dev-tools "
7 PR = "r1"
8
9 inherit xfce46
10
11 EXTRA_OECONF += "--disable-dependency-tracking --disable-static --with-broken-putenv=yes"
12
13 MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
14
15 do_stage() {
16         install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
17         # The line below expands to the list of headers that native makefile
18         # would install.  Complain and/or fix if it's not portable enough
19         for file in  $(eval $(make -n -C libxfce4util install|grep "^list='[^.]\\+.h"|cut -d\; -f1); echo $list); do 
20                 install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
21         done
22
23         oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
24
25 }
26
27 FILES_${PN}-dev += " ${datadir}/xfce4/m4"