surpport seeking the recorded video
[vuplus_openembedded] / recipes / xfce-base / exo_0.3.4.bb
1 DEPENDS = "libxfce4util xfce-mcs-manager hal liburi-perl-native python-native"
2
3 inherit xfce
4 XFCE_VERSION = 4.4.2
5
6 SRC_URI += " file://configure.patch;patch=1"
7 SRC_URI += " file://exo-no-tests.patch;patch=1"
8
9 # Note: Python checking is broken
10 do_configure_prepend() {
11         sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.in
12 }
13
14 do_stage() {
15     autotools_stage_all
16 }
17
18 FILES_${PN} += "${datadir}/xfce4/ \
19                 ${libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so"
20 FILES_${PN}-dev += "${libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.*"
21 FILES_${PN}-dbg += "${libdir}/xfce4/mcs-plugins/.debug/exo-preferred-applications-settings.*"