surpport seeking the recorded video
[vuplus_openembedded] / recipes / wifistix / wifistix-modules_5.0.16.p0.bb
1 # FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
2 # located in the work directory. see module.bbclass
3
4 DESCRIPTION = "Linux Driver for Marvel 88W8385 802.11b/g Wifi Module used in Gumstix daughtercards"
5 SECTION = "base"
6 PRIORITY = "optional"
7 HOMEPAGE = "http://www.gumstix.com"
8 LICENSE = "GPL"
9 RDEPENDS = "kernel (${KERNEL_VERSION})"
10 DEPENDS = "virtual/kernel"
11 PR = "r0"
12
13 SRC_URI = "http://files.gumstix.com/cf8385-5.0.16.p0-26306.tbz \
14                         file://wifistix.conf \
15                         file://mcf25 \
16                         file://marvell-devicename.patch;patch=1 \
17                         file://marvell-devicetable.patch;patch=1 \
18                         file://marvell-gumstix.patch;patch=1 \
19                         file://sbi-no-inline.patch;patch=1 \
20                         file://2.6.17-new-pcmcia-layer.patch;patch=1 \
21                         file://bad-cast.patch;patch=1 \
22                         file://sk_buff.patch;patch=1 \
23                         file://struct-changes.patch;patch=1 \
24                         file://no-more-config-h.patch;patch=1 \
25                         file://realtime-kernel.patch;patch=1 \
26                         file://install-properly.patch;patch=1 \
27                         file://fix-essid-truncation.patch;patch=1"
28
29 S = "${WORKDIR}/src_cf8385"
30
31 inherit module-base
32
33 EXTRA_OEMAKE = 'CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 \
34                 KERNELDIR="${KERNEL_SOURCE}" ARCH="${TARGET_ARCH}" \
35                 CC="${KERNEL_CC}" EXTRA_CFLAGS="${CFLAGS}" \
36                 INSTALL_MOD_PATH="${D}"'
37
38 do_compile() {  
39         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
40         oe_runmake
41 }
42
43 do_install() {  
44         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
45         oe_runmake install
46
47         install -m 0755 -d ${D}${sysconfdir}/modprobe.d
48         install -m 0644 ${WORKDIR}/wifistix.conf ${D}${sysconfdir}/modprobe.d/wifistix.conf
49         install -m 0755 -d ${D}${sysconfdir}/modutils
50         install -m 0644 ${WORKDIR}/mcf25 ${D}${sysconfdir}/modutils/mcf25
51 }
52
53 FILES_${PN} = "${base_libdir}/modules/"
54 FILES_${PN} += "${sysconfdir}/modprobe.d/"
55 FILES_${PN} += "${sysconfdir}/modutils/"
56 CONFFILES_${PN} = "${sysconfdir}/modprobe.d/wifistix.conf"
57 CONFFILES_${PN} += "${sysconfdir}/modutils/mcf25"
58