Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / vuplus / vuplus-dvb-tools.bb
1 DESCRIPTION = "Small utilities specific to the Vuplus dvb receiver (for DVB v3)"
2 SECTION = "base"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5
6 PV = "1.7"
7 PR = "r0"
8
9
10 SRC_URI = "file://showiframe.c"
11
12 SRC_URI += "file://showiframe.pro"
13
14 inherit qmake
15
16 UTILS = "showiframe"
17
18 do_configure_prepend() {
19         cd ${S}/
20         echo "TEMPLATE=subdirs" > dmutils.pro
21         echo "CONFIG=console" >> dmutils.pro
22         echo "SUBDIRS=${UTILS}" >> dmutils.pro
23         install -d ${S}/showiframe
24         install -m 0644 ${WORKDIR}/showiframe.c ${S}/showiframe/showiframe.c
25         install -m 0644 ${WORKDIR}/showiframe.pro ${S}/showiframe/showiframe.pro
26 }
27
28 do_install() {
29         install -d ${D}/${bindir}/
30         for u in ${UTILS}
31         do
32                 install -m 0755 ${S}/${u}/${u} ${D}/${bindir}/
33         done
34 }