[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / vlc / x264_r2245.bb
1 DESCRIPTION = "H.264 encoder"
2 LICENSE = "GPL"
3 PR = "r4"
4
5 X264PV = "snapshot-20090928-2245"
6
7 SRC_URI = "http://download.videolan.org/pub/videolan/x264/snapshots/x264-${X264PV}.tar.bz2"
8
9 S = "${WORKDIR}/${PN}-${X264PV}"
10
11 inherit autotools lib_package pkgconfig
12
13 # default --extra-cflags
14 X264_ECFLAGS = ""
15
16 # disable use of assembler written functions
17 X264_DISABLE_ASM = "--disable-asm"
18 # use assembler written functions for those archs supporting this
19 X264_DISABLE_ASM_x86 = ""
20 DEPENDS_x86 = "yasm-native"
21
22 EXTRA_OECONF = '--enable-shared ${X264_DISABLE_ASM} --extra-cflags="${X264_ECFLAGS}"'
23
24 do_stage() {
25         autotools_stage_all
26 }