[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / vlc / vlc_1.0.2.bb
1 # This recipe packages vlc as a library as well, so qt4 dependencies
2 # can be avoided when ony the library is installed.
3 # Would be cool if when newer vlc is added to OE and older ones are phased
4 # out that could be made the default.
5
6 require vlc.inc
7
8 # ffmpeg from git (library version => 52) is required
9 # libtool-native must be >= 2.2.4
10 DEPENDS += "libdvdcss libdvdread"
11
12 EXTRA_OECONF += "\
13         --enable-dvdread \
14 "
15
16 LEAD_SONAME = "libvlc.so.2"
17
18 PACKAGES =+ "libvlc-dbg libvlc-dev libvlc"
19
20 FILES_libvlc-dev = "${libdir}/lib*.so"
21
22 FILES_libvlc-dbg = "\
23         ${libdir}/.debug \
24         ${libdir}/vlc/meta_engine/.debug \
25         ${libdir}/vlc/audio_filter/.debug ${libdir}/vlc/audio_output/.debug \
26         ${libdir}/vlc/demux/.debug ${libdir}/vlc/control/.debug \
27         ${libdir}/vlc/gui/.debug ${libdir}/vlc/packetizer/.debug \
28         ${libdir}/vlc/audio_mixer/.debug ${libdir}/vlc/stream_out/.debug \
29         ${libdir}/vlc/mux/.debug ${libdir}/vlc/access/.debug \
30         ${libdir}/vlc/visualization/.debug ${libdir}/vlc/access_filter/.debug \
31         ${libdir}/vlc/access_output/.debug ${libdir}/vlc/video_output/.debug \
32         ${libdir}/vlc/services_discovery/.debug ${libdir}/vlc/video_chroma/.debug \
33         ${libdir}/vlc/video_codec/.debug ${libdir}/vlc/video_filter/.debug \
34         ${libdir}/vlc/misc/.debug ${libdir}/vlc/codec/.debug \
35         "
36
37 FILES_libvlc = "${libdir}/lib*.so.*"
38
39 FILES_${PN} += "${bindir}/vlc \
40         ${datadir}/applications \
41         ${datadir}/vlc/ \
42         "
43
44 FILES_${PN}-dbg += "${libdir}/vlc/*/.debug"