Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / update-modules / update-modules_1.0.bb
1 SECTION = "base"
2 DESCRIPTION = "Script to manage module configuration files"
3 LICENSE = "GPLv2"
4 PACKAGE_ARCH = "all"
5 RDEPENDS = "${@base_contains("MACHINE_FEATURES", "kernel26",  "module-init-tools-depmod","modutils-depmod",d)} "
6 PR = "r9"
7
8 SRC_URI = "file://update-modules"
9
10 pkg_postinst() {
11 if [ "x$D" != "x" ]; then
12         exit 1
13 fi
14 update-modules
15 }
16
17 do_install() {
18         install -d ${D}${sbindir}
19         install ${WORKDIR}/update-modules ${D}${sbindir}
20 }
21
22 # The SlugOS distro is testing the use of the busybox mod* utilities.
23 # If that works out, we should create a virtual/update-modules, and
24 # let the distros select if they want busybox, or some other package
25 # to provide it.  Until then, the following line just removes the
26 # unwanted dependencies for SlugOS.
27 RDEPENDS_slugos = ""
28 RDEPENDS_opendreambox = ""
29 RDEPENDS_vuplus = ""