surpport seeking the recorded video
[vuplus_openembedded] / recipes / u-boot / u-boot_git.bb
1 require u-boot.inc
2 PR ="r38"
3
4 FILESPATHPKG =. "u-boot-git:"
5
6 SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git "
7 SRCREV_davinci-sffsdr = "4b50cd12a3b3c644153c4cf393f4a4c12289e5aa"
8 SRCREV_akita = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
9 SRCREV_spitz = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
10 SRCREV_c7x0 = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
11 SRCREV_afeb9260 = "6b8edfde22acc574b5532e9f086e6a7287a9bc78"
12 SRCREV_afeb9260-180 = "6b8edfde22acc574b5532e9f086e6a7287a9bc78"
13 SRCREV_palmpre = "6b8edfde22acc574b5532e9f086e6a7287a9bc78"
14 SRCREV_cm-t35 = "3c014f1586d5bfe30dca7549396915c83f31cd30"
15 SRC_URI_append_afeb9260 = " file://AFEB9260-network-fix.patch;patch=1"
16 SRC_URI_append_afeb9260-180 = " file://AFEB9260-network-fix.patch;patch=1"
17 SRC_URI_append_cm-t35 = "file://cm-t35/cm-t35.patch;patch=1"
18
19 SRC_URI_beagleboard = "git://git.denx.de/u-boot-ti.git;protocol=git \
20                  file://fw_env.config \
21                  file://new-pinmux.patch;patch=1 \
22 file://revision-detection.patch;patch=1 \
23 file://i2c.patch;patch=1 \
24 file://720MHz.patch;patch=1 \
25 file://dss.patch;patch=1 \
26 "
27
28 SRCREV_beagleboard = "a5cf522a91ba479d459f8221135bdb3e9ae97479"
29 PV_beagleboard = "2009.11-rc1+${PR}+gitr${SRCREV}"
30
31 SRCREV_calamari = "f67066b6b0740b826ed862615c5ab022aaf4779a"
32 PV_calamari = "2009.08+${PR}+gitr${SRCREV}"
33 SRC_URI_append_calamari = " file://buggy-gcc-really-no-spe.patch;patch=1"
34
35 SRC_URI_omap3-touchbook = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
36                  file://fw_env.config \
37                  file://dss2.patch;patch=1 \
38                  file://600mhz.patch;patch=1 \
39                  file://new-pinmux.patch;patch=1 \
40                  file://spi3.patch;patch=1 \
41                  file://spi4.patch;patch=1 \
42                  file://headphone.patch;patch=1 \
43                  file://power.patch;patch=1 \
44                  file://ai-logo.patch;patch=1 \
45                  file://mmcinit.patch;patch=1 \
46                  file://touchbook-config.patch;patch=1 \
47 "
48 SRCREV_omap3-touchbook = "d363f9cb0918a1b6b92e2e20d01543d0c4f53274"
49 PV_omap3-touchbook = "2009.05+${PR}+gitr${SRCREV}"
50
51
52 SRC_URI_omap3evm = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git"
53 SRCREV_omap3evm = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
54 PV_omap3evm = "2009.03+${PR}+gitr${SRCREV}"
55
56
57 SRCREV_am3517-evm = "e60beb13cf0"
58 SRC_URI_append_am3517-evm = " \
59 file://omap3evm/0001-Changes-for-making-a-NAND-build.patch;patch=1 \
60 file://omap3evm/0002-Fix-for-NFS-boot-for-OMAP3-EVM.patch;patch=1 \
61 file://omap3evm/0003-OMAP3-timer-handling-to-1ms-tick-and-CONFIG_SYS_HZ-t.patch;patch=1 \
62 file://omap3evm/0004-Reverse-patch-for-NFS-boot-to-fix-comments-provided.patch;patch=1 \
63 file://omap3evm/0005-SMC911x-driver-fixed-for-NFS-boot.patch;patch=1 \
64 file://omap3evm/0006-Added-OMAP3517-3505-support.patch;patch=1 \
65 file://omap3evm/0007-OMAP3517TEB-validated-on-OMAP3517TEB-board.patch;patch=1 \
66 file://omap3evm/0008-OMAP3517PRE-ALPHA-validated-on-OMAP3517PRE_ALPHA-bo.patch;patch=1 \
67 file://omap3evm/0009-OMAP3517PRE-ALPHA-DDR-size-issue-fixed.patch;patch=1 \
68 file://omap3evm/0010-OMAP3517PRE-ALPHA-Mux-configuration-for-MMC-CD-and.patch;patch=1 \
69 file://omap3evm/0011-Ethernet-driver-functional-no-need-for-time-delay.patch;patch=1 \
70 file://omap3evm/0012-EMAC-driver-Implement-GPIO-driven-PHY-reset.patch;patch=1 \
71 file://omap3evm/0013-Cleaned-up-during-EVM-hang-issue.patch;patch=1 \
72 file://omap3evm/0014-EMAC-driver-cleanup-removed-debug-prints.patch;patch=1 \
73 file://omap3evm/0015-EMAC-driver-Check-for-link-status-in-packet-send-lo.patch;patch=1 \
74 file://omap3evm/0016-Config-option-and-name-changed-to-omap3517_evm.patch;patch=1 \
75 "
76 PV_am3517-evm = "2009.03+${PR}+gitr${SRCREV}"
77
78 SRC_URI_omapzoom = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;protocol=git"
79 SRCREV_omapzoom = "d691b424f1f5bf7eea3a4131dfc578d272e8f335"
80 PV_omapzoom = "2009.01+${PR}+gitr${SRCREV}"
81
82 SRCREV_omapzoom2 = "3672cd5c3b53d219d33345eebad4e25ad5bf6d52"
83 PV_omapzoom2 = "2009.05+${PR}+gitr${SRCREV}"
84
85 SRC_URI_overo = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
86                  file://fw-env.patch;patch=1 \
87                  file://dss2.patch;patch=1 \
88 "
89 SRCREV_overo = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
90 PV_overo = "2009.03+${PR}+gitr${SRCREV}"
91
92 # Davinci dm355-evm/dm365-evm/dm6446-evm - PSP.03.01.00.28 (Phase 3 build 28)
93
94 SRC_URI_dm355-evm    = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
95 SRCREV_dm355-evm     = "f8d047c84137ab331c0ee2c3e94c3f1ec4228298"
96 PV_dm355-evm         = "2009.10+2009.11-rc1+${PR}+gitr${SRCREV}"
97
98 SRC_URI_dm365-evm    = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
99 SRCREV_dm365-evm     = "f8d047c84137ab331c0ee2c3e94c3f1ec4228298"
100 PV_dm365-evm         = "2009.10+2009.11-rc1+${PR}+gitr${SRCREV}"
101
102 SRC_URI_dm6446-evm   = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
103 SRCREV_dm6446-evm    = "f8d047c84137ab331c0ee2c3e94c3f1ec4228298"
104 PV_dm6446-evm        = "2009.10+2009.11-rc1+${PR}+gitr${SRCREV}"
105
106 # Davinci dm6467-evm/dm6467-evm - PSP.03.02.00 (DM6467 Beta)
107
108 SRC_URI_dm6467-evm   = "git://arago-project.org/git/people/hemant/u-boot-dm646x.git;protocol=git"
109 SRCREV_dm6467-evm    = "b037106746e5b942d7ef06bfcd776a7cdfe32f68"
110 PV_dm6467-evm        = "1.3.4+${PR}+gitr${SRCREV}"
111
112 SRC_URI_dm6467t-evm  = "git://arago-project.org/git/people/hemant/u-boot-dm646x.git;protocol=git"
113 SRCREV_dm6467t-evm   = "b037106746e5b942d7ef06bfcd776a7cdfe32f68"
114 PV_dm6467t-evm       = "1.3.4+${PR}+gitr${SRCREV}"
115
116 # OMAPL da380-omapl137/da850-omapl138-evm/hawkboard - PSP 3.20.00.07 (Beta)
117
118 SRC_URI_da830-omapl137-evm = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
119 SRCREV_da830-omapl137-evm  = "0d291f2f255e6d66a78b3dc2445362a96ae39a57"
120 PV_da830-omapl137-evm      = "2009.08+gitr${SRCREV}"
121
122 SRC_URI_da850-omapl138-evm = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
123 SRCREV_da850-omapl138-evm  = "0d291f2f255e6d66a78b3dc2445362a96ae39a57"
124 PV_da850-omapl138-evm      = "2009.08+gitr${SRCREV}"
125
126 SRC_URI_hawkboard          = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
127 SRCREV_hawkboard           = "0d291f2f255e6d66a78b3dc2445362a96ae39a57"
128 PV_hawkboard               = "2009.08+gitr${SRCREV}"
129
130 SRC_URI_dm355-leopard = "git://www.denx.de/git/u-boot-arm.git;protocol=git;branch=next \
131                         file://leopardboard-support.patch;patch=1 \
132 "
133 SRCREV_dm355-leopard = "86d5c98d3d97d631b1d3a5f5e6a17e87c99b42cf"
134 PV_dm355-leopard = "2009.05+2009.06-rc2+gitr${SRCREV}"
135
136 SRC_URI_neuros-osd2 = "git://github.com/neuros/u-boot.git;protocol=git;branch=neuros"
137 SRCREV_neuros-osd2 = "8de979d346624c0e4cfe2e5c0f08ce20ca4b5d14"
138
139 SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git"
140 SRCREV_sequoa = "cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093"
141
142 SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git;tag=cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093 "
143
144 SRC_URI_mini2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"
145 SRCREV_mini2440 = "3516c35fb777ca959e5cadf2156a792ca10e1cff"
146
147 SRC_URI_micro2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"
148 SRCREV_micro2440 = "3516c35fb777ca959e5cadf2156a792ca10e1cff"
149
150 SRC_URI_neuros-osd2 += "file://Makefile-fix.patch;patch=1"
151 SRC_URI_append_akita = "file://pdaXrom-u-boot.patch;patch=1 \
152                         file://uboot-eabi-fix-HACK2.patch;patch=1 \
153                         file://akita-standard-partitioning.patch;patch=1 \
154                        "
155 SRC_URI_append_spitz = "file://pdaXrom-u-boot.patch;patch=1 \
156                         file://uboot-eabi-fix-HACK2.patch;patch=1 \
157                         file://spitz-standard-partitioning.patch;patch=1 \
158                        "
159 SRC_URI_append_c7x0 = "file://pdaXrom-u-boot.patch;patch=1 \
160                        file://uboot-eabi-fix-HACK2.patch;patch=1 \
161                        file://corgi-standard-partitioning.patch;patch=1 \
162                        "
163 SRC_URI_sheevaplug = "git://git.denx.de/u-boot-marvell.git;protocol=git;branch=testing"
164 SRCREV_sheevaplug = "119b9942da2e450d4e525fc004208dd7f7d062e0"
165
166 S = "${WORKDIR}/git"
167
168
169 do_configure_prepend_akita() {
170         sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
171 }
172
173 do_configure_prepend_spitz() {
174         sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
175 }
176
177 do_configure_prepend_c7x0() {
178         sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/corgi.h
179 }
180
181 do_compile_append_sheevaplug() {
182         oe_runmake u-boot.kwb
183 }
184
185 UBOOT_IMAGE_sheevaplug = "u-boot-${MACHINE}-${PV}-${PR}.kwb"
186 UBOOT_BINARY_sheevaplug = "u-boot.kwb"
187 UBOOT_SYMLINK_sheevaplug ?= "u-boot-${MACHINE}.kwb"
188
189 do_deploy_prepend_mini2440() {
190         cp ${S}/u-boot-nand16k.bin ${S}/u-boot.bin
191 }
192
193 do_deploy_prepend_micro2440() {
194         cp ${S}/u-boot-nand16k.bin ${S}/u-boot.bin
195 }