add amos tp
[vuplus_openembedded] / recipes / tuxbox / tuxbox-common.bb
1 DESCRIPTION = "Tuxbox common files"
2 LICENSE = "GPL"
3 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
4
5 PN = "tuxbox-common"
6 PR = "r2"
7 SRCDATE = "20090305"
8 PV = "0.0+cvs${SRCDATE}"
9
10 SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox/;module=cdk/root/share/tuxbox;method=ext;tag=dreambox;date=${SRCDATE} \
11         http://dreamboxupdate.com/download/opendreambox/tuxbox-common-r11.tar.gz \
12         file://satellites_20110916.patch;patch=1;pnum=0"
13
14 FILES_${PN} = "/"
15
16 S = "${WORKDIR}/tuxbox-common-r11"
17
18 TRANSPONDER_LISTS = "satellites.xml terrestrial.xml"
19
20 #enigma1 need a cables.xml
21 TRANSPONDER_LISTS_append_dm7020 = " cables.xml"
22 TRANSPONDER_LISTS_append_dm500plus = " cables.xml"
23 TRANSPONDER_LISTS_append_dm600pvr = " cables.xml"
24
25 do_install() {
26         install -d ${D}/etc/init.d
27         install -d ${D}/etc/rcS.d
28         install -d ${D}/etc/tuxbox/
29         install -d ${D}/usr/share/tuxbox
30         install -m 0644 ${S}/scart.conf ${D}/etc/tuxbox/scart.conf
31
32         install -m 0644 ${S}/timezone.xml ${D}/etc/tuxbox/timezone.xml
33         ln -sf /etc/tuxbox/timezone.xml ${D}/etc/
34
35         ln -sf /usr/share ${D}/share
36
37         for i in ${TRANSPONDER_LISTS}; do
38                 install -m 0644 ${WORKDIR}/tuxbox/$i ${D}/etc/tuxbox/$i
39                 ln -sf /etc/tuxbox/$i ${D}/etc/;
40                 ln -sf /etc/tuxbox/$i ${D}/usr/share/;
41                 ln -sf /etc/tuxbox/$i ${D}/usr/share/tuxbox/;
42         done;
43 }