surpport seeking the recorded video
[vuplus_openembedded] / recipes / tmake / tmake_1.11.bb
1 SRC_URI = "ftp://ftp.trolltech.com/pub/freebies/tmake/tmake-${PV}.tar.gz"
2 DESCRIPTION = "tmake is an easy-to-use tool for creating and maintaining makefiles across many platforms and compilers."
3 LICENSE = "Unknown"
4 DEPENDS = ""
5 SECTION = "devel"
6 PRIORITY = "optional"
7
8 S = "${WORKDIR}/tmake-${PV}"
9
10 # Ick. This .bb file should really have a -native version doing this, even if it is a perl script... RP
11 do_stage() {
12         install -m 0755 bin/tmake bin/progen ${STAGING_BINDIR_NATIVE}/
13
14         install -d ${STAGING_DATADIR}/tmake
15         cp -R lib/* ${STAGING_DATADIR}/tmake/
16 }
17
18 do_install() {
19         install -d ${D}${bindir}
20         install -m 0755 bin/tmake bin/progen ${D}${bindir}/
21
22         install -d ${D}${datadir}/tmake
23         cp -R lib/* ${D}${datadir}/tmake/
24 }
25
26 PACKAGES = "${PN}-dbg tmake"
27 FILES = ""
28 FILES_tmake="${bindir} ${datadir}/tmake"