task-vuplus-enigma2.bb : append led brightness setup, ultimo
[vuplus_openembedded] / recipes / tasks / task-x11.bb
1 DESCRIPTION = "The X Window System -- install this task to get a client/server based display multiplexer."
2 SECTION = "x11/server"
3 LICENSE = "MIT"
4 PV = "1.0"
5 PR = "r2"
6
7 # WORK IN PROGRESS
8
9 inherit task
10
11 PACKAGES += "\
12   ${PN}-server \
13   ${PN}-utils \
14 "
15
16 RRECOMMENDS_${PN} = "\
17   ${PN}-server \
18   ${PN}-utils \
19 "
20
21 # Some machines don't set a *runtime* provider for X, so default to Xfbdev here
22 # virtual/xserver won't work, since the kdrive recipes will build multiple xserver packages
23 XSERVER ?= "xserver-kdrive-fbdev"
24
25 # This is also the reason why we have to make this package machine specific :/
26 PACKAGE_ARCH_${PN}-server = "${MACHINE_ARCH}"
27
28 RDEPENDS_${PN}-server = "\
29   ${XSERVER} \
30 "
31
32 RDEPENDS_${PN}-utils = "\
33   xserver-kdrive-common \
34   xserver-nodm-init \
35   xauth \
36   xhost \
37   xset \
38   xrandr \
39 "
40