task-vuplus-enigma2 : add remotecontrolcode plugin to uno & ultimo
[vuplus_openembedded] / recipes / tasks / task-vuplus-wlan.bb
1 DESCRIPTION = "Vuplus: W-LAN Task for the Vuplus Distribution"
2 SECTION = "vuplus/base"
3 LICENSE = "MIT"
4 PR = "r4"
5
6 inherit task
7
8 #
9 # task-vuplus-wlan
10 #
11 DESCRIPTION_${PN} = "Vuplus: W-LAN Support"
12 DEPENDS_${PN} = "enigma2-plugins"
13 RDEPENDS_${PN} = "\
14   ${@base_contains("MACHINE_FEATURES", "vuwlan", "enigma2-plugin-systemplugins-wirelesslansetup", "enigma2-plugin-systemplugins-wirelesslan", d)} \
15   wireless-tools \
16   wpa-supplicant \
17 "
18
19 WLAN_CRYPTO_MODULES = "\
20   kernel-module-aes-generic \
21   kernel-module-arc4 \
22   kernel-module-ecb \
23   kernel-module-cryptomgr \
24   kernel-module-crypto-hash \
25   kernel-module-aead \
26   kernel-module-pcompress \
27   kernel-module-crypto-blkcipher \
28   kernel-module-crypto-algapi \
29 "
30
31 WLAN_PCI_MODULES = "\
32   kernel-module-ath5k \
33 "
34
35 WLAN_USB_MODULES = "\
36   kernel-module-rt73usb \
37   kernel-module-zd1211rw \
38   rt73-firmware \
39   zd1211-firmware \
40 "
41
42 WLAN_USB_MODULES_LEGACY = "\
43   zd1211b \
44   wlan-rt73 \
45   r8712u \
46   rt3070 \
47   r8192cu \
48 "
49
50 RDEPENDS_${PN}_append_bm750 = "\
51   ${@base_contains('PREFERRED_VERSION_linux-bm750', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
52 "
53
54 RDEPENDS_${PN}_append_vusolo = "\
55   ${@base_contains('PREFERRED_VERSION_linux-vusolo', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
56 "
57
58 RDEPENDS_${PN}_append_vuuno = "\
59   ${@base_contains('PREFERRED_VERSION_linux-vuuno', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
60 "
61
62 RDEPENDS_${PN}_append_vuultimo = "\
63   ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
64 "
65
66 PACKAGE_ARCH = "${MACHINE_ARCH}"
67