Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / tasks / task-vuplus-enigma2.bb
1 DESCRIPTION = "Vuplus: Enigma2 Task for the Vuplus Distribution"
2 SECTION = "vuplus/base"
3 LICENSE = "MIT"
4 PR = "r0"
5
6 inherit task
7
8 PROVIDES = "\
9   task-vuplus-ui \
10   ${PACKAGES} \
11 "
12
13 PACKAGES = "\
14   task-vuplus-enigma2 \
15 "
16
17 #
18 # task-vuplus-enigma2
19 #
20 RPROVIDES_task-vuplus-enigma2 = "task-vuplus-ui"
21 DESCRIPTION_task-vuplus-enigma2 = "Vuplus: Enigma2 Dependencies"
22 RDEPENDS_task-vuplus-enigma2 = "\
23   dreambox-blindscan-utils \
24   enigma2 \
25   enigma2-defaultservices \
26   enigma2-plugin-extensions-mediascanner \
27   enigma2-plugin-systemplugins-factorytest \
28   enigma2-streamproxy \
29   tuxbox-tuxtxt-32bpp \
30 "
31
32 RRECOMMENDS_task-vuplus-enigma2 = "\
33   aio-grab \
34   python-crypt \
35   python-netserver \
36   python-twisted-core \
37   python-twisted-protocols \
38   python-twisted-web \
39   enigma2-plugin-extensions-mediaplayer \
40   enigma2-plugin-extensions-pictureplayer \
41   enigma2-plugin-systemplugins-skinselector \
42   ${@base_contains("MACHINE_FEATURES", "wifi", "task-vuplus-wlan", "", d)} \
43 "
44
45 RDEPENDS_task-vuplus-enigma2_append_bm750 = "\
46   enigma2-plugin-systemplugins-fancontrol \
47 "
48
49 PACKAGE_ARCH = "${MACHINE_ARCH}"