task-vuplus-enigma2 : add remotecontrolcode plugin to uno & ultimo
[vuplus_openembedded] / recipes / tasks / task-slugos.bb
1 # This describes a generic SlugOS image, even though the bb file is
2 # called 'slugos-image.bb' the distro specific configuration is
3 # done in conf/distro/${DISTRO}.conf (which should always include
4 # conf/distro/slugos.conf to get the standard settings).
5 #
6 DESCRIPTION = "Task packages for the SlugOS distribution"
7 HOMEPAGE = "http://www.nslu2-linux.org"
8 LICENSE = "MIT"
9 PR = "r24"
10 PACKAGE_ARCH = "${MACHINE_ARCH}"
11 COMPATIBLE_MACHINE = "(nslu2|ixp4xx|sheevaplug)"
12 ALLOW_EMPTY = "1"
13
14 #----------------------------------------------------------------------------------
15 # FIRMWARE CONFIGURATION
16 #----------------------------------------------------------------------------------
17 # EXTRA PACKAGES
18 # --------------
19 # The standard firmware contents and additional packages built as requirements
20 # of the firmware are defined here in SLUGOS_STANDARD_RDEPENDS.  This represents
21 # the standard set of software for the 8-MByte NSLU2 device.
22 SLUGOS_STANDARD_RDEPENDS = ""
23 SLUGOS_STANDARD_RRECOMMENDS = ""
24 SLUGOS_MACHINE_RDEPENDS = ""
25 SLUGOS_MACHINE_RRECOMMENDS = ""
26
27 # The full cpio (non-busybox) is required for turnup and sysconfig.
28 SLUGOS_STANDARD_RRECOMMENDS += "\
29 cpio \
30 "
31
32 # These lines add support for formatting ext2 and ext3 file systems
33 # on a hard disk attached to the NSLU2.  ext3 is the standard Linux
34 # file system.
35 SLUGOS_STANDARD_RRECOMMENDS += "\
36 e2fsprogs-mke2fs \
37 e2fsprogs-fsck \
38 e2fsprogs-e2fsck \
39 e2fsprogs-badblocks \
40 e2fsprogs-blkid \
41 "
42
43 # Filesystem selection.  Adding entries here adds the module to the
44 # image.  The module must be built as part of nslu2-kernel (i.e. it
45 # must be specified as a module in the defconfig file).  The NLS
46 # support charset modules must be given explicitly and must match
47 # the codepage/iocharset and NLS handling for the file systems which
48 # require them.  The installed lanugage set is minimal but sufficient
49 # for any file system (since it uses utf8).  See
50 # http://www.nslu2-linux.orgwiki/HowTo/MountFATFileSystems
51 # for more information on the language behaviour of the DOS file
52 # systems.
53 #
54 # KERNEL LEVEL FILE SYSTEM SUPPORT
55 # --------------------------------
56 # NOTE: removing kernel-module-nfs from this list will prevent NFS
57 # boot (however you can do a simple flash file system boot - no
58 # attached disk - and install the nfs modules from ssh.)
59 # The altboot mechanism requires kernel-module-loop.
60 SLUGOS_STANDARD_RRECOMMENDS += "\
61 kernel-module-ext2 \
62 kernel-module-jbd \
63 kernel-module-ext3 \
64 kernel-module-vfat \
65 kernel-module-nls-cp437 \
66 kernel-module-nls-utf8 \
67 kernel-module-nfs \
68 "
69
70 # Add modules required for usb support
71 SLUGOS_STANDARD_RRECOMMENDS += "\
72 kernel-module-ehci-hcd \
73 kernel-module-ohci-hcd \
74 kernel-module-uhci-hcd \
75 "
76
77 # Add packages and modules required for RAID-1 support
78 SLUGOS_STANDARD_RRECOMMENDS += "\
79 mdadm \
80 kernel-module-md-mod \
81 kernel-module-raid1 \
82 "
83
84 # Add the machine-specific RRECOMMENDS stuff -- kernel modules required for
85 # network support.
86 SLUGOS_MACHINE_RRECOMMENDS_nslu2 = "\
87 kernel-module-mii \
88 kernel-module-ixp4xx-mac \
89 kernel-module-ixp4xx-qmgr \
90 "
91
92 # Add machine-specific RDEPENDS stuff - packages such as the NPE firmware
93 SLUGOS_MACHINE_RDEPENDS_nslu2 = "\
94 ixp4xx-npe \
95 "
96
97 DISTRO_EXTRA_DEPENDS ?= ""
98 DEPENDS += "${DISTRO_EXTRA_DEPENDS}"
99
100 DISTRO_EXTRA_RDEPENDS ?= ""
101
102 ## This comment block is temporary, to be removed once SlugOS 5.0 stabilizes
103 ##RDEPENDS += "\
104 ##      kernel ixp4xx-npe \
105 ##      base-files base-passwd netbase \
106 ##        busybox initscripts-slugos slugos-init \
107 ##        update-modules sysvinit tinylogin udev \
108 ##      module-init-tools modutils-initscripts \
109 ##        ipkg-collateral ipkg ipkg-link \
110 ##      libgcc \
111 ##      beep \
112 ##      util-linux-mount \
113 ##      util-linux-umount \
114 ##      util-linux-swaponoff \
115 ##      util-linux-losetup \
116 ##      ${SLUGOS_STANDARD_RDEPENDS} \
117 ##      ${DISTRO_EXTRA_RDEPENDS}"
118 ## SlugOS 5.0 - original RDEPENDS above for reference; tinylogin and the
119 ## util-linux-* utilities are now replaced by busybox tools.  Also, ipkg
120 ## is replaced by a trimmed-down version of opkg (no package signatures,
121 ## and it uses the busybox wget command instead of libcurl - MJW
122 ## SlugOS 5.0 - module-init-tools replaced by busybox as well - MJW
123 ## SlugOS 5.2 - module-init-tools reinstated due to busybox bugs - MJW
124 ## SlugOS 5.4 - util-linux-mount reinstated due to busybox bugs - MJW
125
126 RDEPENDS += "\
127         kernel \
128         base-files base-passwd netbase \
129         busybox initscripts-slugos slugos-init \
130         update-modules sysvinit udev \
131         module-init-tools modutils-initscripts \
132         opkg-collateral ${IPKG_VARIANT} \
133         libgcc \
134         beep \
135         util-linux-mount \
136         ${SLUGOS_STANDARD_RDEPENDS} \
137         ${SLUGOS_MACHINE_RDEPENDS} \
138         ${DISTRO_EXTRA_RDEPENDS}"
139
140 DISTRO_EXTRA_RRECOMMENDS ?= ""
141 RRECOMMENDS += "\
142         openssh \
143         ${SLUGOS_STANDARD_RRECOMMENDS} \
144         ${SLUGOS_MACHINE_RRECOMMENDS} \
145         ${DISTRO_EXTRA_RRECOMMENDS}"