add plugin(3g-modem-manager)
[vuplus_openembedded] / recipes / tasks / task-shr-minimal.bb
1 DESCRIPTION = "SHR Lite Image Feed"
2 PR = "r20"
3 PV = "2.0"
4 LICENSE = "GPL"
5
6 inherit task
7
8 def get_rdepends(bb, d):
9     enabled = bb.data.getVar("ENABLE_BINARY_LOCALE_GENERATION", d, 1)
10
11     # If locale is disabled, bail out
12     if not enabled:
13         return
14
15     locales = bb.data.getVar("GLIBC_GENERATE_LOCALES", d, 1)
16     if not locales or locales == "all":
17         locales = bb.data.getVar("IMAGE_LINGUAS", d, 1);
18
19     libc = bb.data.getVar('LIBC', d, 1)
20     import re
21
22     rdepends = ""
23     if not locales or locales == "all":
24         # if locales aren't specified, or user has written "all"
25         import os
26         ipkdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
27
28         regexp1 = re.compile(libc+"-binary-localedata-.*") # search pattern
29         regexp2 = re.compile("_.*") # we want to remove all version info and file extension
30
31         for root, subFolders, files in os.walk(ipkdir):
32             for file in files:
33                 if regexp1.search(file):
34                     file = regexp2.sub("", file)
35                     rdepends = "%s %s" % (rdepends, file)
36
37     else:
38         # if locales are specified
39         regexp1 = re.compile("\\..*") # We want to turn en_US.UTF-8 into en_US
40         regexp2 = re.compile("_")     # We want to turn en_US into en-US
41
42
43         for locale in locales.split(" "):
44             locale = regexp1.sub("", locale)
45             locale = regexp2.sub("-", locale)
46             locale = str.lower(locale)
47             rdepends = "%s %s-binary-localedata-%s" % (rdepends, libc, locale)
48     return rdepends
49
50
51
52
53 PACKAGES += "\
54         ${PN}-base \
55         ${PN}-cli \
56         ${PN}-fso \
57         ${PN}-audio \
58         ${PN}-x \
59         ${PN}-apps \
60         ${PN}-gtk \
61 "
62
63
64
65 RDEPENDS_${PN}-base = "\
66   netbase \
67   sysfsutils \
68   modutils-initscripts \
69   module-init-tools-depmod \
70   rsync \
71   screen \
72   fbset \
73   fbset-modes \
74   openssh-sftp-server \
75   cron \
76   logrotate\
77   util-linux-ng-fdisk \
78   shr-splash \
79 "
80
81 RDEPENDS_${PN}-cli = "\
82   screen \
83   nano \
84   iptables \
85   mtd-utils \
86   s3c24xx-gpio \
87   mickeydbus \
88   mickeyterm \
89 "
90
91 RDEPENDS_${PN}-fso = "\
92   fsoraw \
93   opimd-utils-cli \
94   python-codecs \
95   python-gst \
96 "
97
98
99 #FIXME: libcanberra-alsa should be pulled in by fsodeviced but isn't
100 RDEPENDS_${PN}-audio = "\
101   alsa-utils-aplay \
102   alsa-utils-amixer \
103   libcanberra-alsa \
104 "
105
106 RDEPENDS_${PN}-audio_append_om-gta01 = "\
107   alsa-scenarii-shr \
108 "
109
110 RDEPENDS_${PN}-audio_append_om-gta02 =  "\
111   alsa-scenarii-shr \
112 "
113
114 RDEPENDS_${PN}-x = "\
115   glibc-utils \
116   glibc-charmap-utf-8 \
117   e-wm-menu-shr \
118   shr-wizard \
119   shr-theme-gry \
120   etk-theme-shr \
121   ${@get_rdepends(bb, d)} \
122   libx11-locale \
123   libmokoui2 \
124   xcursor-transparent-theme \
125   xinput-calibrator \
126 "
127
128 RDEPENDS_${PN}-apps = "\
129   fso-abyss \
130   phoneui-apps-messages \
131   phoneui-apps-contacts \
132   phoneui-apps-dialer \
133   phonefsod \
134   phoneuid \
135   libphone-ui \
136   libphone-ui-shr \
137   ffalarms \
138   shr-settings \
139   shr-theme \
140   calc \
141 "
142
143
144 RDEPENDS_${PN}-gtk = "\
145   openmoko-icon-theme-standard2 \
146   shr-theme-gtk-e17lookalike \
147   vala-terminal \
148   tangogps \
149   pyphonelog \
150   matchbox-keyboard-im \
151 "
152