add plugin(3g-modem-manager)
[vuplus_openembedded] / recipes / tasks / task-sdl.bb
1 DESCRIPTION = "Tasks for SDL stuff"
2 LICENSE = "MIT"
3 PR = "r2"
4
5 inherit task
6
7 PACKAGES = "\
8   task-sdl-libs \
9   task-sdl-games \
10   task-sdl-emulators \
11 #  task-sdl-misc \
12 "
13
14 # no need to add libsdl as all libsdl-* already rdepend on it
15 RDEPENDS_task-sdl-libs = "\
16   libsdl-gfx \
17   libsdl-image \
18   libsdl-mixer \
19   libsdl-ttf \
20   libsdl-net \
21 "
22
23 RDEPENDS_task-sdl-games = "\
24   abuse \
25   crimsonfields \
26   freedroid \
27   frozen-bubble \
28   lbreakout2 \
29   nogravity \
30   horizon \
31   openttd \
32   prboom \
33   quake1 \
34   quetoo \
35   rocksndiamonds \
36   rott \
37   supertux \
38   uqm \
39   xmame \
40   "
41
42 RDEPENDS_task-sdl-emulators = "\
43   dgen-sdl \
44   dosbox \
45   e-uae \
46   fceu \
47   frodo \
48   scummvm \
49   snes9x \
50 "
51
52 RDEPENDS_task-sdl-others = "\
53   synaestehsia \
54   chibitracker \
55   gnash \
56   midpath \
57 "
58
59 # ./powermanga/powermanga_0.79.bb:DEPENDS = "libsdl-qpe libsdl-mixer"
60
61
62
63
64