More task bb clean up
[vuplus_openembedded] / recipes / tasks / task-opie.bb
1 DESCRIPTION = "Tasks for OPIE stuff"
2 SECTION = "opie/base"
3 LICENSE = "MIT"
4
5 PR = "r13"
6
7 inherit task
8
9 PROVIDES = "task-opie-everything"
10
11 PACKAGES = "task-opie-base \
12             task-opie-base-applets task-opie-base-apps \
13             task-opie-base-decorations task-opie-base-inputmethods \
14             task-opie-base-pim task-opie-base-settings \
15             task-opie-base-styles task-opie-base-todayplugins \
16             task-opie-extra-settings \
17             task-opie-extra-styles \
18   ${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
19   ${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
20            "
21
22 RDEPENDS_task-opie-everything := "${PACKAGES}"
23
24 PACKAGES += "task-opie-everything"
25
26 #
27 # Dependencies to get the launcher up and running
28 #
29 RDEPENDS_task-opie-base = "opie-init opie-alarm opie-qcop opie-qss opie-quicklauncher \
30                            opie-taskbar opie-pics opie-sounds opie-freetype \
31                            ttf-dejavu-sans ttf-dejavu-sans-mono"
32 # Recommend both landscape and portrait backgrounds
33 RRECOMMENDS_task-opie-base = "opie-taskbar-images-${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
34                               opie-taskbar-images-${MACHINE_DISPLAY_HEIGHT_PIXELS}x${MACHINE_DISPLAY_WIDTH_PIXELS}"
35
36 PACKAGE_ARCH_task-opie-base = "${MACHINE_ARCH}"
37
38 #
39 # things for reasonable bootstrap image
40 #
41 RDEPENDS_task-opie-base-applets = "opie-aboutapplet opie-clockapplet opie-suspendapplet \
42                                    opie-homeapplet opie-rotateapplet \
43                                    opie-brightnessapplet opie-volumeapplet \
44                                    opie-screenshotapplet \
45     ${@base_contains("COMBINED_FEATURES", "irda", "opie-irdaapplet", "",d)} \
46     ${@base_contains("MACHINE_FEATURES", "apm", "opie-batteryapplet", "",d)} \
47     ${@base_contains("COMBINED_FEATURES", "pcmcia", "opie-cardapplet", "",d)} \
48     ${@base_contains("MACHINE_FEATURES", "keyboard", "opie-vtapplet opie-logoutapplet", "",d)}"
49
50 PACKAGE_ARCH_task-opie-base-applets = "${MACHINE_ARCH}"
51
52 #
53 # clamshell models can benefit from the autorotate applet
54 #
55 RDEPENDS_task-opie-base-applets_append_c7x0   = " opie-autorotateapplet"
56 RDEPENDS_task-opie-base-applets_append_spitz  = " opie-autorotateapplet"
57 RDEPENDS_task-opie-base-applets_append_akita  = " opie-autorotateapplet"
58
59 RDEPENDS_task-opie-base-inputmethods = "opie-multikey opie-handwriting opie-handwriting-classicset"
60
61 RDEPENDS_task-opie-base-apps = "opie-console opie-clock opie-citytime opie-backup opie-sysinfo \
62                        opie-advancedfm"
63
64 RDEPENDS_task-opie-base-settings = "opie-packagemanager opie-light-and-power opie-appearance \
65                            opie-systemtime opie-networksettings opie-button-settings \
66                            opie-icon-reload opie-launcher-settings opie-security \
67                            opie-securityplugin-pin"
68
69 #
70 # That settings can be removed and device will be still usable
71 #
72 RDEPENDS_task-opie-extra-settings = "opie-language opie-doctab opie-mediummount \
73     ${@base_contains("DISTRO_FEATURES", "wifi", "opie-networksettings-wlanplugin", "",d)} \
74     ${@base_contains("DISTRO_FEATURES", "ppp", "opie-networksettings-pppplugin", "",d)} \
75                             "
76
77 PACKAGE_ARCH_task-opie-extra-settings = "${MACHINE_ARCH}"
78
79 RDEPENDS_task-opie-base-decorations = "opie-deco-flat opie-deco-liquid opie-deco-polished"
80
81 RDEPENDS_task-opie-base-styles = "opie-style-flat opie-style-fresh opie-style-web opie-style-phase"
82
83 #
84 # Those styles are big and does not look good on QVGA screen
85 #
86 RDEPENDS_task-opie-extra-styles = "opie-style-liquid opie-style-metal"
87
88 RDEPENDS_task-opie-base-todayplugins = "opie-today-addressbookplugin opie-today-datebookplugin \
89                                opie-today-todolistplugin"
90
91 RDEPENDS_task-opie-base-pim = "opie-addressbook opie-datebook opie-drawpad \
92                       opie-search opie-textedit opie-today opie-todo \
93                       task-opie-base-todayplugins \
94                       opie-datebook-birthdayplugin"
95
96 RDEPENDS_task-opie-bluetooth = "bluez-utils obexftp obexpush libopieobex0 \
97                        opie-bluepin opie-bluetoothmanager opie-bluetoothapplet"
98
99 RDEPENDS_task-opie-irda = "irda-utils libopieobex0 obexftp obexpush"