More task bb clean up
[vuplus_openembedded] / recipes / tasks / task-openprotium.bb
1 DESCRIPTION = "Basic image for openprotium"
2 HOMEPAGE = "http://www.openprotium.org"
3 ALLOW_EMPTY = "1"
4 PR = "r1"
5
6 inherit task
7
8 PACKAGE_ARCH = "${MACHINE_ARCH}"
9 # be sure to build the kernel:
10 DEPENDS = "virtual/kernel"
11
12 # always make this one for testing.
13 DISTRO_KERNEL_MODULES = "kernel-module-dummy"
14 # do we still need this?
15 DISTRO_KERNEL_MODULES += "kernel-module-af-packet"
16 # unused for now
17 #DISTRO_KERNEL_MODULES += "kernel-module-netconsole"
18
19 # these are listed separately because the are not needed 
20 # for boot, but are needed by reflash, etc.
21 DISTRO_EXTRA_RDEPENDS += "diffutils cpio findutils"
22
23 # pick up the fw_set/get env utils.
24 DISTRO_EXTRA_RDEPENDS += "u-boot-utils"
25
26 RDEPENDS = " kernel \
27         base-files \
28         base-passwd \
29         netbase \
30         busybox \
31         openprotium-init \
32         initscripts-openprotium \
33         update-modules \
34         module-init-tools \  
35         modutils-initscripts \
36         ipkg-collateral ipkg ipkg-link \
37         portmap \
38         e2fsprogs-blkid \
39         mdadm \
40         hdparm \
41         mtd-utils \
42         ${DISTRO_SSH_DAEMON} \
43         ${DISTRO_DEV_MANAGER} \
44         ${DISTRO_INIT_MANAGER} \
45         ${DISTRO_LOGIN_MANAGER} \
46         ${DISTRO_KERNEL_MODULES} \
47         ${MACHINE_EXTRA_RDEPENDS} \
48         ${DISTRO_EXTRA_RDEPENDS} "
49
50 RRECOMMENDS += " \
51         ${DISTRO_EXTRA_RRECOMMENDS} \
52         ${MACHINE_EXTRA_RRECOMMENDS}"